OpenText Intelligent Capture: Standard Import suddenly failing to import emails from o365 using OAuth
Issue:
Standard Import suddenly failing to import emails.
Cause:
The Client Secret key has expired.
Resolution:
Generate a Client Secret key with a valid expiration date.
IDEA
Refer to the attached KB article for more information on configuring oAuth for the email connection
The error messages in Designer and the Standard Import trace
logs at default level may not be specific enough to identify the issue.
Run Standard Import with tracelevel:debug parameter to
get more logging info.
In Designer, the email connection test fails with error message:
“Unable
to connect to the server”.
Standard Import logging at the default logging level
shows:
00:00:10.076 Tid=16,Connected to MailServer:
outlook.office365.com, connection name: ABCOAuth.
00:00:10.165 Tid=16,Failed to load messages list from
MailServer: outlook.office365.com, connection name: ABCOAuth.
00:00:10.276 Tid=16,Custom module dispose failed. Error:
Unable connect to the server: outlook.office365.com.
Standard Import logging with tracelevel:debug parameter shows a more detailed information:
at
System.Threading.Tasks.Task`1.GetResultCore(Boolean waitCompletionNotification)
at
Emc.InputAccel.Import.Email.OauthTokenProvider.ObtainAADToken()
---> (Inner Exception #0)
MSAL.Desktop.4.17.1.0.MsalServiceException:
ErrorCode:
invalid_client Microsoft.Identity.Client.MsalServiceException: A
configuration issue is preventing authentication - check the error message from
the server for details.You can modify the configuration in the application
registration portal. See https://aka.ms/msal-net-invalid-client for details. Original exception: AADSTS7000222: The provided client secret keys for
app 'd100b49e-68a9-44c8-93f8-3383f7c366f0' are expired. Visit the Azure portal
to create new keys for your app: https://aka.ms/NewClientSecret, or consider
using certificate credentials for added security: https://aka.ms/certCreds.