Issue:
You are unable to access xPlore Administrator console.
When browsing to http://host:9300/dsearchadmin, you get the error “404 Not Found” instead of the login page.
Cause:
Invalid IPv6 address in XhiveDatabase.bootstrap causing dsearchadmin.war deployment failure.
Resolution:
Update IP address XhiveDatabase.bootstrap and redeploy dsearchadmin.war
1. Stop Documentum xPlore PrimaryDsearch service
2. Update the IP address in XhiveDatabase.bootstrap under xplore_home/config.
In this case, the invalid IPv6 address was changed to an IPv4 address.
3. Rename xPlore/config/XhiveDatabase.bootstrap.lock to XhiveDatabase.bootstrap.lock-backup
4. Delete tmp folder under xPlore_home\wildfly17.0.1\server\DctmServer_PrimaryDsearch.
5. Delete dsearchadmin.war.failed and create a “dsearchadmin.war.dodeploy” file under xPlore_home\wildfly17.0.1\server\DctmServer_PrimaryDsearch\deployments.
6. Start Documentum xPlore PrimaryDsearch service
INFO:
The following error message was logged in several locations - server.log, dsearchadminweb.log, dsearchadmin.war.failed.
WFLYCTL0186: Services which failed to start: service jboss.deployment.unit."dsearchadmin.war".undertow-deployment: javax.servlet.ServletException: com.emc.documentum.core.fulltext.adminweb.server.exception.EngineException: com.xhive.error.XhiveException: UNKNOWN_HOST: The host name {0} could not be resolved, Original message: no scope_id found