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Chapter 1

Introduction

Identification and Completion together enable people to quickly classify documents
and validate extracted data that the automated Classification and Extraction
modules failed to classify and validate.

Unless otherwise indicated this guide applies to both Completion and Identification.

Note: The Completion, Identification, and Extraction modules support
document type scripts. For more information, see OpenText Intelligent Capture -
Scripting Guide (ECPCORE-PSC).

1.1 Concepts
Before you begin to receive work, ensure you review and understand the
terminology.

Batch
A batch is a group of pages to be processed as a unit using a predetermined set
of instructions specified in a process. All information scanned or imported into
the system is stored in a batch. Batches are structured hierarchically and
represent different processing levels. The batch tree structure includes up to 8
levels, with 0 (page) being the lowest and 7 (batch) being the highest.

Node
A node represents a processing level in the batch hierarchy. Pages, documents,
and folders are examples of nodes.

Task
A task, also referred to as work, is a unit of work that you process. The level is
determined by the process designer. Work can be a page, a document, or higher,
up to an entire batch.

The operator selects work, either a particular batch of documents or all batches
available. Batches are created on the server from the series of scanned or
imported electronic pages. A batch can be arranged into a multilevel hierarchy
of folders, documents, and pages.

The server controls the processing of each batch. Identification, or manual
classification, is one of the batch processing steps that typically follows
automatic classification. When a portion of a batch is ready for manual
classification, the server forms a task and sends it to the operator who has
signed up for this batch. Typically, after the operator has completed manual
classification, the batch is returned to the server, which sends it for automatic
data extraction and then manual data validation using Completion.
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Page
A page is a single-sided image that is scanned, faxed, or received electronically
into an Intelligent Capture Server. One or more pages make up a document.
Document pages display in the Documents panel as thumbnails. The images are
numbered and are ordered by page location, first to last, within the batch tree.

Document
A document represents a physical, printed document, fax, or email message that
has been converted into digitized data by scanning or importing it into an
Intelligent Capture Server. For example, a telephone bill or an invoice. A
document can be composed of multiple pages.
A document represents the level 1 node in the batch tree structure and is
displayed in the Documents panel.
Each document has a sequence number that identifies its position within the
folder, starting with 1. A document name is also shown if it is defined by the
document type designer.

Folder
A folder is a virtual container for documents and pages. It represents the level 2
node in the batch tree structure. Folders display in the Documents panel for
tasks that are at level 2 and above.
Each folder has a position number followed by the folder name (if it is defined
by the designer). The number is relative to the task level. For example, if the task
is at level 3 (folder), then the folders are numbered 1, 2, 3, and so on. If the task is
at level 4, then the folders in the first level 4 node are numbered 1.1, 1.2, and so
on; in the second level 4 node, they are numbered 2.1, 2.2, and so on.

Higher-Level Node
A higher-level node in the tree structure is represented in the Documents panel by
a separator line between folders.

1.2 Identification
Intelligent Capture Identification completes and corrects the automatic classification
process by enabling operators to manually classify all documents that were not
classified automatically by the Classification module. Operators classify documents
as follows:

• For both recognition and information extraction projects, operators assign
documents to document types.

• For recognition projects, operators also assign pages to templates, which have
been defined in a recognition project. In addition, data validation might also be
required.

The Identification module is an attended module, meaning that an operator must
manually interact with the module to successfully process data through to the next
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step. Batches selected for processing during production open automatically in the
Identification production window where the operator can complete and correct
automatic classification that was performed during the Classification step.

The Identification module requires the following configuration and components to
operate successfully:

Includes the module as a step within a process
The Identification module interfaces with Intelligent Capture Servers through a
process file. To use the module, include it as a step within a process. The process
must be compiled into an IAP file and be used in a production environment.

Uses settings defined in setup mode
Before you run the module within a process in production, you must configure
it. To do this, run the module for setup and define specific configuration settings
for module within the process. You can set up the module at the process level or
batch level.

Has two project types
The Identification module uses one of the following types of projects:

• Recognition project (DPP): The DPP file is created using the Recognition
Designer application and contains the templates, base images, and rules for
processing documents. You can use a single DPP file for all document capture
jobs or create different project files based on specific processing needs.
Specify the DPP file to use during module setup; therefore, each task the
module receives can potentially use a different DPP file. During production,
the module loads the DPP file into memory and keeps it there until it receives
a task that specifies a different project file or until the module exits. The DPP
files must be stored in a location that is accessible to all machines that run the
module.

• Information extraction project: Contains profiles that define classification
and extraction. Information extraction projects use document types as work
items. Pages are classified by assigning a document type and can be flagged.
Neither templates nor index fields are used.

Processes tasks in production mode
To process tasks using the module, run the Identification module for
production. Once the module is started for production, you can choose the mode
in which to process tasks.

Includes special error handling instructions to handle runtime errors
When the module completes a task successfully during production, it sets the
<TaskResult> IA value to 0. If the module determines an error has occurred while
processing a task, the module sets <ExportResult> to a non-zero value and logs
the error message to the Intelligent Capture Server Event log. When an error
occurs, even when one or more of the pages in the task could have produced the
error, the module finishes the task with a Success status provided it can process
the rest of the pages in the task and the Skip node that produced the error and
continue with remaining nodes option is selected during module setup. The

1.2. Identification
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Success status causes the module to run the Finish event so that the step can
call its Finish event handler. The module fires the Error event only if the task
finishes with a Failure status. A Failure status can result when the task is
aborted, either because of user response to an error prompt or when the Abort
entire task option is selected during module setup. In this situation, the module
should call an Error event handler. The Error event handler in the process
should check the exception in the <ErrorText> IA value to determine the cause of
the error, and then take the appropriate action.

1.2.1 Operator Procedure
The Identification operator procedure includes the following steps:

1. The operator selects work and starts receiving tasks.

2. The operator receives the task. The task is displayed in the main window.

A task can include a single page or multiple pages arranged into documents and
higher-level folders.

3. The operator works on the task. When processing a task, the operator can
expand and view the task structure in a special panel of the main window.
Documents and pages that require attention are marked with icons and color
shading, helping the operator select work items and view the progress.

Note: Page mode allows operators to use Identification for rapid image
quality assurance. The module enters the one-page mode when triggered
on the page level (level 0). For information extraction projects, operators
can only flag the page.

• For recognition projects, the operator performs the following actions:

a. Identifies the type of each document if not identified automatically.

b. Verifies that all document pages are assigned a document type and
assigns a document type manually where necessary.

c. Verifies that all document pages are assigned a page template, and
assigns a template manually where necessary.

d. Verifies that all index fields specific for a particular page include values
exactly as they are shown on the image of the page. If necessary, the
operator edits index fields.

e. Flags documents and pages to indicate their special status as defined by
the business process.

f. Annotates pages to hide sensitive information, to highlight particular
data on the image, or to add a note.

• For information extraction projects, the operator performs the following
actions:

a. Identifies the type of each document if not identified automatically.
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b. Flags documents and pages to indicate their special status as defined by
the business process.

c. Annotates pages to hide sensitive information, to highlight particular
data on the image, or to add a note.

4. When the task is completed, the operator sends it back to the server. The
operator can also return an incomplete task to the server queue to defer and
finish this task later.

5. If work (a batch or all batches) is not finished, the operator receives the next task
from the server.

It the task is not ready, Identification enters the waiting mode. When the next
task is received, Identification exits the waiting mode automatically.

6. When work has finished, Identification enters the waiting mode. The operator
can exit the waiting mode and get more work.

1.3 Completion
Completion is Intelligent Capture's unified, high-performance operator client that
provides a full-featured interface for indexing images and validating index data. The
main benefits include:

• Document types that can span multiple pages and can automatically navigate to
the correct page for an index field. This feature eliminates the need for operators
to search page-by-page for an index field.

A document type is the data entry form that Completion operators use for
validation. It consists of fields and controls, a layout, a set of validation rules, and
document and field properties. A document type can cover multiple pages or no
pages.

The designer creates document types using Intelligent Capture Designer.

• Data entry featuring configurable layout, styles, rich controls, user-defined
shortcuts, form segmentation, field summary, drop-down image snippets,
annotations, auto-navigation to configured work, and close integration with
Intelligent Capture recognition technology.

• A configurable document, page, and field-flagging mechanism.

• Multiple table support including table OCR smart-extraction.

• High-performance indexing and keyboard-only operation.

• Field finder enables searching of text within the field labels and content.

• Work mode allows Intelligent Capture administrators to mix-and-match
functionality and design the operator job.

• Page mode allows operators to use Completion for rapid image quality
assurance. The module enters the one-page mode when triggered on the page
level (level 0).

• Visualization of PDF documents.

1.3. Completion
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• Page filtering mode restricts operator activities to pages that require attention.

• Validation rules that support expression-, script-, or data query-based automatic
checking of multiple fields, including data in table rows.

Note: Whereas Identification processes pages, Completion is not dependent on
pages and instead processes data fields extracted from pages. Those data fields
are organized into a collection of index values that are further grouped
together into a document object. Therefore, even if a Completion task does not
contain pages, an operator can still create empty document nodes, assign
document types to them, and then enter index values for fields defined for the
selected document types. All defined population and validation rules are also
executed. The operator can even set flags on fields and documents. All the
index values, manually entered by the operator, are saved in the batch and
processed by subsequent CaptureFlow steps.
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Chapter 2

Setting Up the Modules

Most configuration information for Intelligent Capture client modules is defined
during module setup. You can run a module in setup mode from Intelligent Capture
Designer, from Intelligent Capture Administrator, or from a command prompt with
appropriate arguments. For more information, see OpenText Intelligent Capture -
Module Reference (ECPCORE-CMD).

When launched in setup mode, a client module displays the Setup window in which
you can specify the module's configuration settings.

2.1 Setup Options for All Modules
For options that apply to the view and behavior of all modules, including
Completion and Identification, you use Intelligent Capture Administrator and
Intelligent Capture Designer.

Notes

• For visual styles (such as font, background/foreground color as well as batch
level names and the thumbnail default size to be displayed in the
Documents panel) and keyboard shortcuts, select the Configuration tab in
Intelligent Capture Designer.

• To set the timeout value for Completion and Identification, use Intelligent
Capture Administrator.

2.2 Configuring direct population of fields with data
from the image (Identification and Completion)

Note: For Identification, indexing is not available for information extraction
(IE) projects.

You can use the Click to Extract feature or basic rubberbanding to directly populate
fields with data from the image. In comparison to basic rubberbanding, Click to
Extract provides additional functionality. For example, using Click to Extract, you
can automatically populate the current field with a single click of a word; in
addition, the name of the current field and other useful information is displayed
when the pointer is positioned over a word. However, you must enable Click to
Extract by using the OCR data cache, whereas basic rubberbanding is available by
default; although, basic rubberbanding can also optionally use the OCR data cache.

When CaptureFlow uses an information extraction project, the OcrDataCache
parameter value can also be populated from a previous Classification or Extraction
step. Note that this will still not work for advanced recognition-based projects, but if
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you are using only information extraction, this simplifies the workflow because you
can skip the Standard OCR step if you were using it only to generate OCR data.

Enabling Click to Extract

To enable the Click to Extract feature, assign the OcrDataCache IA value to
Completion or Identificationfrom the Standard OCR step as follows:
Assign to <Completion> | <Identification>:0.OCRDataCache the value StandardOCR:
0.OCRDataCache

Note: By default, click to Extract overrides the use of CTRL+left-click/right-
click to zoom in/out on the image. To use these key combinations for zooming
in/out on the image, in Intelligent Capture Designer, set System > System
Configuration tab > Other Options > Global Options > Intelligent Capture
Desktop > CtrlClickBehavior to Image Zoom.

Enabling the OCR data cache for basic rubberbanding (optional)

To improve the performance of basic rubberbanding, you can use the associated
OCR data cache to fill in the rubberbanded fields. That is, when the Standard OCR
step precedes Completion or Identification, the OCR data cache produced by the
Standard OCR module can be used to fill in the rubberbanded fields instead of
running the full page OCR reading for each field.

To use OCR data cache in the desktop client modules, ensure the following is
performed:

• The OcrDataCache IA value is passed to Completion or Identificationfrom the
Standard OCR step.

To do this, in the CaptureFlow assign to
<Completion>/<Identification>:0.OCRDataCache the value
StandardOCR:0.OCRDataCache.

• Rotation was not applied to the image. The Rotation IA value is equal to 0.

• In Recognition Designer >Project Options > Standard OCR tab:

– The Enable OCR data cache from Standard OCR option is enabled.

– The list of engines for recognizing specific data prior to data from Standard
OCR does not include the OCR engine for zone/free-form extraction.

Note: OCR data cache is relevant to the page processed on the StandardOCR
step. If annotations were applied to the page during the next steps to hide
sensitive data, it might become visible in case when OCR data cache is used for
rubberbanding.
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2.3 Setting Up Identification
These topics describe how to set up the Identification module.

2.3.1 Configuring Operator View and Workflow for Efficiency
Table 2-1: Identification Setup: View and Navigation Settings

Element Description

Display backsides of pages Displays the backsides of pages in the
Documents panel; otherwise, they are not
displayed.

A page is considered a backside if its
Backside input IA value is assigned a value
of 1.

Auto-advance to next page When all work on the current page has been
completed, the operator is automatically
advanced to the next page that needs work.
If the current page is the last page in the task,
then the behavior is defined by the Auto-
advance to next task setting.

Note: This option applies if
Identification is triggered at the
Document level (level 1) or higher.

Auto-advance to next document When all work in the current document has
been completed, the operator is
automatically advanced to the next
document that needs work.

Note: This option applies if
Identification is triggered at the
Document level (level 1) or higher.

Auto-advance to next task When all work in the current task has been
completed, the operator is not prompted and
automatically advanced to the next task;
otherwise, the operator is prompted to
advance to the next task.

Note: If the current task still has work
to be done, then the focus stays in the
current field.

2.3. Setting Up Identification
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Element Description

Prompt to confirm change of document
classification

The operator is prompted to confirm
changing a document type or a template
code; otherwise, the operator is not
prompted.

Note: This setting works with
automatic template assignment.

Display image snippets Small image snippets are displayed near the
data entry fields in the Index Fields panel;
otherwise, no image snippets are displayed.

Note: Indexing is not available for
information extraction projects.

2.3.2 Enabling the Operator to Perform Certain Tasks
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Table 2-2: Identification Setup: Permissions

Element Description

Allowed template codes Specifies the primary filter for populating the
pick lists on the document nodes in the
Documents panel. Depending on the Select
templates based on setting, the pick list is
populated with template codes in either this
filter or document type templates.

Specify the filter as follows:

• Leave the default value (*) to use all
template codes available in the
recognition project and then filter this list
using the Allowed document types filter
(below).

• Specify the list of allowed template codes.
Add one template code per line, pressing
ENTER to start a new line.

Use the wildcard (*) to specify a group of
template codes. For example, Invoice*
stands for all codes that start with
“Invoice”.

• Clear the list to disable the document
classification. The operator will not be
able to expand the pick list and assign a
document type or a template code to a
document.

Notes
• Alternatively, the list of allowed

template codes can be passed to the
step's AllowedDocTypes IA value.
In production, the assigned IA value
will take precedence over the setting
specified during step setup.

• The filter specified in this setup
setting or passed in the
AllowedDocTypes IA value can be
further refined by the
BeforeShowDocumentList() API
method (document type scripting).
For more information, see OpenText
Intelligent Capture - Scripting Guide
(ECPCORE-PSC).

• Templates are not used in
information extraction projects.

Allow task to finish with incomplete work Select this option to allow the operator to
finish the task with unclassified pages.

2.3. Setting Up Identification
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Element Description

Show only generic templates Select this option to display only generic
templates in the Template List panel.

If not selected, the Template List panel
displays all kinds of templates.

Note: Templates are not used in
information extraction projects.

Assign last used template to multiple pages Select this option to allow the operator to
select multiple pages in the Documents
panel and assign the last used template to all
of them.

Notes
• This option applies if Identification

is triggered at the Document level
(level 1) or higher.

• Templates are not used in
information extraction projects.

Abandon changes Select this option to allow the operator to
close the task without saving changes as long
as there are no task tree structure or image
changes.

If not selected, the canceled task returns to
the server with all changes saved; no prompt
is displayed.

Edit images Select this option to allow the operator to
rotate images.

Annotate images Select this option to allow the operator to
annotate images. If images have been
annotated prior to the Identification step, the
operator can view these annotations on
images in the page view.

If not selected, the Annotations palette is
unavailable. The operator cannot apply, edit,
or remove annotations, or view existing
annotations in the page view.

Note: This setting does not affect the
way how pages are displayed in the
Documents panel. The page
thumbnails are always displayed with
annotations if such are available.
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Element Description

Copy pages Select this option to allow the operator to
copy and paste pages in the Documents
panel.

Note: This option applies if
Identification is triggered at the
Document level (level 1) or higher.

Copy documents Select this option to allow the operator to
copy and paste documents in the Documents
panel.

Note: This option applies if
Identification is triggered on or above
the Document level (level 1).

Move pages Select this option to allow the operator to cut
and paste pages within the current document
and between documents in the Documents
panel.

Note: This option applies if
Identification is triggered at the
Document level (level 1) or higher.

Move documents Select this option to allow the operator to cut
and paste documents within the current
folder and between folders in the
Documents panel.

Note: This option applies if
Identification is triggered on or above
the Document level (level 1).

Delete pages Select this option to allow the operator to
delete unnecessary pages from documents in
the Documents panel.

Note: This option applies if
Identification is triggered at the
Document level (level 1) or higher.

Delete documents Select this option to allow the operator to
delete unnecessary documents (with all
pages) in the Documents panel.

Note: This option applies if
Identification is triggered on or above
the Document level (level 1).

2.3. Setting Up Identification
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Element Description

Delete folders Select this option to allow the operator to
delete unnecessary folders (with all
documents) in the Documents panel.

Note: This option applies if
Identification is triggered on or above
the Folder level (level 2).

Print pages Select this option to allow the operator to
print pages and documents.

When cleared, printing is disabled.

Print overlay Select this option to add a task name and
document rank to a single print page.

When cleared, this additional information is
not added to a single print page.

Flag pages and documents Select this option to allow the operator to flag
pages and documents.

If not selected:

• The operator cannot set or remove flags.

• The main window hides all Flag buttons
and related menu options.

• If the task has pages and/or documents
flagged on the previous CaptureFlow
steps, the operator sees such flags in the
Documents panel and that bottom of the
Page View panel. However, the operator
cannot operate these imported flags.

Chapter 2   Setting Up the Modules

20 OpenText™ Intelligent Capture ECPCORE220300-CCV-EN-01



Element Description

Allowed document types Click the <n> options link to specify the
secondary filter for populating the pick lists
on the document nodes in the Documents
panel. Depending on the Select templates
based on setting, the pick list will be
populated with the allowed document types
or with the codes of the templates defined in
the allowed document types.

This filter is used if the Allowed template
codes filter is set to “*” (“use all template
codes”). In this case, the primary filter selects
from the recognition project all template
codes, or document types associated with all
template codes available. Next, the selection
is filtered using the Allowed document
types filter.

Depending on the desired outcome, specify
the allowed document types as follows:

• Leave the default value (*) to fetch all
document types or template codes from
the recognition project.

• Specify the list of allowed document
types. Add one document type per line,
pressing ENTER to start a new line.

Use the wildcard (*) to add a group of
document types. For example, Invoice*
will result in all document types that start
with “Invoice”.

• Clear the list to leave the pick list empty.
The operator will not be able to classify
documents.

Notes
• Alternatively, the list of allowed

document types can be passed to the
step's AllowedDocTypes IA value.
In production, the assigned IA value
will take precedence over the setting
specified during step setup.

• The filter specified in this setup
setting or passed in the
AllowedDocTypes IA value can be
further refined by the
BeforeShowDocumentList() API
method (document type scripting).
for more information, see OpenText
Intelligent Capture - Scripting Guide
(ECPCORE-PSC).
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Element Description

Organize documents Select this option to allow the operator to
create empty documents and split and merge
documents in the Documents panel.

If not selected, these operations are not
allowed.

Note: If the recognition project (DPP)
linked to the task defines the binding
field, this setup option is ignored
during runtime. The operator does not
have access to commands New
document, New empty document, and
Merge document. The respective menu
options and toolbar buttons are not
displayed (hidden).

Show batch structure up to level Select this option to allow the operator to
hide nodes above the specified level from the
Documents panel. Options: levels 2 to 6.

Organize folders up to level Select this option to allow the operator to
merge, split, and create nodes in the
Documents panel on and above the selected
level. Values:

• Levels 2 to 6

• None: Disables merging, splitting, and
creating nodes above the Document level
(level 1).

2.3.3 Configuring Template Assignment

Note: Templates are not used in information extraction projects.

Automatic Template Assignment

When the automatic template assignment mode is enabled, the operator classifies a
document manually, after which all document pages are classified automatically.
Technically, the operator expands the pick list on the document the Documents
panel and selects the list item – a document type or a template code. The Identification
engine fetches from the recognition project all templates associated with the selected
list item. The fetched items are sorted either by template ID (matches the template
order in the recognition project) or by template name. This sorting take places in the
array of selected templates and does not affect the template order in the recognition
project or in the Template List panel. The sorted array of templates is assigned to all
document pages in the “one to one” manner. If the number of pages in a document
exceeds the number of templates in the array, the last template is assigned to all
remaining pages.
To configure automatic template assignment, do the following:
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• Specify whether the pick list will display document types or template codes.

• Specify the parameter by which the array of selected templates will be sorted.

• Choose to show or hide a warning when the operator selects a list item without
associated templates.

• Enable the automatic template assignment mode to force it on the operator's
machine when they receive a new task for processing. The operator can enable
and disable automatic assignment in the scope of a task.

Manual Template Assignment

For manual template assignment, configure the behavior and displayed content of
the Template List panel, namely:

• Template assignment based on template codes: Enable this feature to hide the
Template Name column from the Template List panel and display template
codes only.

• Template List panel sorting: Enable this feature to display five most recently
used templates on top of the Template List panel.

• Template List panel filtering: Enable this feature to filter the Template List panel
to show templates that belong to the document type or code assigned to the
document currently selected in the Documents panel.

The Template List panel configuration applies by default when the operator
receives a task. The operator can enable or disable these settings in the main window
in the scope of a particular task.

Note: Before displayed in the Template List panel, templates can be resorted
or additionally filtered using document type scripting. The
BeforeShowTemplates() method is called every time a different page becomes
active in the Page View panel, that is, when the operator selects a different
item (a page, a document, or higher) in the Documents panel. The
BeforeShowTemplates() method receives the templates already sorted and
filtered as specified during setup or by the operator. This method populates the
Template List panel with the modified content. For more information, see
OpenText Intelligent Capture - Scripting Guide (ECPCORE-PSC).

2.3. Setting Up Identification

ECPCORE220300-CCV-EN-01 Desktop Client Guide: Identification and Completion 23



Identification Setup: Project and Template Assignment

Table 2-3: Identification Setup: Settings

Element Description

Recognition project Select one of the following:

• Information extraction project

• Recognition project (DPP file)

The selected project with all of its page
templates is linked to the Identification
step that you currently set up.

Alternatively, the recognition project can
be assigned to the step's
DispatcherProjectName IA value. In
production, the assigned IA value will
take precedence over the setting specified
during step setup.

Note: If the required project is not in
the list, make sure the following is
true:

• The recognition project is copied to a
shared folder that can be accessed by
the Intelligent Capture Server.

• The UNC path of the shared folder is
specified in the
RecognitionProjectSharedDirectory
parameter in Intelligent Capture
Designer.

• The file with the global options is
uploaded to the Intelligent Capture
Server whose installed CaptureFlow
you set up.

For more information, see OpenText
Intelligent Capture - Designer Guide
(ECPCORE-CPD).
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Element Description

Select templates based on Specify which content will be displayed in
the pick list of a document node in the
Documents panel. Options:

• Document Type: Default. The pick list
displays document types selected from
the recognition project. These document
types must be uploaded on the server.

• Template Code: The pick list displays
template codes selected from the
recognition project. Codes not associated
with any of the templates are not
presented in the pick list. However, a
user will see the code <Undefined> in the
list (this code is associated with the
templates without a template code).

To fetch the required list items from the
recognition project, configure the Allowed
template codes filter (used by default) or the
Allowed document types filter. For more
information, see “Enabling the Operator to
Perform Certain Tasks” on page 16.

Note: Templates are not used in
information extraction projects.

Identify pages by template code Select this option to enable the manual
template assignment by the template code.

• If selected, the Template List panel is
configured to hide the Template Name
field and show the Code field only. Codes
not associated with any of the templates
are not presented on the Template List as
well as the code <Undefined>. The
operator sees and selects template codes.
The Identification engine fetches all
templates with the picked code and
automatically selects one template that
suits best for the given page. To set a
default template when a template is not
automatically matched, use Default
template when there is no match.

• If not selected (default), the Template
List panel is configured to show both the
Template Name field and the Code field.
The operator selects templates from the
Template List panel by name.

Note: Templates are not used in
information extraction projects.
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Element Description

Warn when there is no matching template Select this option to display a warning to the
operator stating that, in the selected template
code, no template matched the image.

Notes
• Identify pages by template code

must be enabled.
• Templates are not used in

information extraction projects.

Default template when there is no match Select one of the following to apply when no
template is matched for the selected template
code:

• Recognition project’s default template

• First template in the selected template
code

Notes
• Identify pages by template code

must be enabled.
• Templates are not used in

information extraction projects.

Auto-assign templates Select this option to enable automatic
template assignment mode.

• If selected, assigning a document type or
a template code (whichever is configured
in the Select templates based on setting)
to a document triggers automatic
reclassification of all pages in that
document.

• If not selected, assigning a document type
or code to a document does not affect
page classification.

Notes
• This option applies if Identification

is triggered at the Document level
(level 1) or higher.

• Templates are not used in
information extraction projects.

Chapter 2   Setting Up the Modules

26 OpenText™ Intelligent Capture ECPCORE220300-CCV-EN-01



Element Description

Auto-assign template order This setting configures automatic template
assignment. Specify the parameter by which
templates selected for automatic assignment
will be sorted in ascending order. Options:

• Template Id: Default. The array of
templates is sorted by the template Id.

• Template Name: The array of templates
is sorted by the template name.

Notes
• If you provide a custom script for

the DocumentIdentified event,
then the script will receive the
template array sorted as specified by
this setting.

• Templates are not used in
information extraction projects.

Filter template list by current document
classification

Select this option to refilter the Template List
panel each time the operator clicks a
different document in the Documents panel
or displays a page belonging to a different
document.

• If selected, the Template List panel is
refiltered to show templates belonging to
the document type or template code of
the active document. Other templates are
hidden. If the document is not assigned a
document type or a template code, all
templates are displayed.

• If not selected, all templates are
displayed.

Notes
• This option applies if Identification

is triggered at the Document level
(level 1) or higher.

• Templates are not used in
information extraction projects.

Warn if the selected document
classification does not contain templates

This setting configures automatic template
assignment. Select this option to display a
warning message to the operator at the
attempt to classify a document with a
document type or template code that does
not have associated templates.

Note: Templates are not used in
information extraction projects.
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Element Description

List most recently used first For recognition projects, templates in the
Template List panel are displayed as
follows:

• If selected, the Template List panel
displays up to five most recently used
templates on top, followed by other
templates sorted alphabetically.

• If not selected, the Template List panel
displays all templates sorted
alphabetically.

For information extraction projects, the
document types list displays the five most
recently used document types on top,
followed by other document types sorted
alphabetically; otherwise, the document
types are sorted alphabetically.

Search items that begin with entered text Select this option to set the default for the
Start typing to filter field to filter on text
with which the template name or code must
start; otherwise, the filter text can appear
anywhere in the template name or code. Also

selects template list settings  > Search
items that begin with entered text.

Note: Templates are not used in
information extraction projects.

Show template sample image • Select this option to show the sample
image of the selected template in the
Template Preview panel.

• If not selected, the sample image is not
displayed.

Note: Templates are not used in
information extraction projects.

Related Topics:

OpenText Intelligent Capture - Designer Guide (ECPCORE-CPD)

OpenText Intelligent Capture - Designer Guide (ECPCORE-CPD)
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2.3.4 Defining the Available Flagging Reasons
Specify the list of page flags and/or document flags that will be available to the
operator.

By default, a single flag is provided for documents with the Rejected flagging
reason. Depending on your business needs, you can remove the default flag, or add
more flagging reasons for documents and/or pages. If you define only one flag (for
pages or for documents), the operator will be able to set and remove it with a single
command, without posting the Reason for Flagging dialog. For instance, the default
configuration (Rejected flag) allows the operator to reject documents by flagging
them.

To specify a flag for pages or documents, add it to the Flag reasons for pages or Flag
reasons for documents list, respectively. Use the following format:

<Display name> (<InternalName>[:<shortcutChar>]).

• The display name is the descriptive flagging reason to be displayed to the
operator.

• The internal name is intended for scripting and regular expressions.

• The shortcut key (one character) is optional.

Example: Too Dark (TooDark) or Too Dark (TooDark:D) (with a shortcut key
specified)

Note: When adding flags to each list, follow the same format – with or without
a shortcut. If you do not specify shortcut keys for all flags in the list, the default
characters will be assigned. If you mix both formats, flags specified without the
shortcut key will be displayed in the Reason for Flagging dialog without a
shortcut character.

Table 2-4: Identification Setup: Flagging Settings

Element Description

Do not classify flagged pages • Select this option to let the operator skip
flagged pages from processing. The task
is done when all pages are either
classified or flagged.

• If not selected, all pages need to be
classified, including flagged pages.

Do not classify flagged documents • Select this option to let the operator skip
pages in flagged documents from
processing.

• If not selected, pages in the flagged
documents need to be classified.
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Element Description

Show prompt when flagging • Select this option to prompt the operator
to continue or cancel the flagging
operation.

• If not selected, the prompt dialog is
suppressed.

Flag reasons for pages Click the <N> Options link to edit the page
flagging reasons that will be displayed to the
operator in the Reason for Flagging dialog.
Add each reason in a new line. The format of
the flagging reason specification is described
above.

Add all flagging reasons in the same format –
with or without a shortcut. If all flagging
reasons are defined without shortcuts, the
default shortcuts will be generated at
runtime. If shortcuts are defined for
particular (not all) flagging reasons, only
these shortcuts will be generated.

Note: You can override this setting for
a step using the AllowedPageFlags
IA value. In production, the assigned
IA value will take precedence over the
setting specified during step setup.

Flag reasons for documents Click the <N> Options link to edit the
document flagging reasons that will be
displayed to the operator in the Reason for
Flagging dialog. Add each reason in a new
line. The format of the flagging reason
specification is described above.

Add all flagging reasons in the same format –
with or without a shortcut. If all flagging
reasons are defined without shortcuts, the
default shortcuts will be generated at
runtime. If shortcuts are defined for
particular (not all) flagging reasons, only
these shortcuts will be generated.

Note: You can override this setting for
a step using the AllowedDocFlags
IA value. In production, the assigned
IA value will take precedence over the
setting specified during step setup.

This option applies if Identification is
triggered on or above the Folder level (level
2).
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Recommendations and Use Cases

• Unless there is a specific reason to do otherwise, all Identification and
Completion steps in a CaptureFlow should be configured with identical page
and document flagging reasons and format. The reason is that when flagged
pages and documents are routed to other steps, flags are transferred in values
PageFlag and DocFlag as sequences of internal names. The display names and
the shortcut characters are not passed to the next step. If the Reason for Flagging
dialog of a given Identification or Completion step receives the flag's internal
name and no definition, the operator will see that internal name; the shortcut will
not be provided.

• If user-defined flags or flags for internal operator messages are required,
consider enabling and instructing operators to use annotations.

• A task will complete even if it is flagged with errors. To ensure all flagged errors
are fixed before the task is complete, route a task back to a supervisor or operator
for completion when the PageStatus.RemainingWork IA value is greater than
zero.

2.3.5 Options for IA Values, Collecting Statistics, and
Scripting
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Table 2-5: Identification Setup: Advanced Settings

Element Description

Output IA value destination Specify output of document fields into
flattened IA values in addition to the original
UIM data structure. Options:

• (Do not write to IA values): Do not
flatten document fields into IA values.
Document fields are output in their
original structure only. This option works
if output is further processed by a
module that directly supports UIM data,
such as Extraction, Completion, or
Standard Export.

• <Step name>: Select the step into whose
values the document data will be
flattened. Output includes both UIM data
and flattened data.

Note: The destination IA values
must be pre-created. If document
data includes array fields (table
data), the number of items in the
array is not known in advance,
therefore, all destination IA values
cannot be pre-created. Consider
using the Output dynamic values
option to enhance data flattening to
dynamically created values.

Notes
• This option applies if Identification

is triggered on or above the
Document level (level 1).

• Not supported for information
extraction projects.

Output dynamic values If data flattening is enabled in the Output IA
value destination setting, select this option
to automatically create dynamic values for
fields that do not have pre-created IA values.

If not selected, document fields are flattened
into matching IA values (if such are found)
and skips fields where no matching IA value
is detected.

Note: Not supported for information
extraction projects.
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Element Description

Collect document type and templates
statistics

Select this option to log statistics in the
Template and DocumentType tables in the
Intelligent Capture database. These statistics,
which are used in reports, are logged for
document types and templates applied by
the operator.

Note: If the Intelligent Capture
database is installed on SQL Server
Express or an internal database is used,
this option is ignored and statistics are
not logged.

Collect field statistics Select this option to log statistics in the
Fields table in the Intelligent Capture
database. These statistics, which are used in
reports, is logged for the data entry fields
updated by the operator.

Notes
• If the Intelligent Capture database is

installed on SQL Server Express or
an internal database is used, this
option is ignored and statistics are
not logged.

• Pre-indexing is not used for
information extraction projects.

Custom value Enter an input string to be passed in to
document type scripting. The format of this
string is defined in scripting. For more
information, see OpenText Intelligent Capture -
Scripting Guide (ECPCORE-PSC).

Script task class name This setting is used by document type
scripting.

Specify the name of the .NET class for each
type of a task derived from <UimScriptTask>.
If this class is not specified in this setting, the
global events in <UimScriptMainCore> will be
invoked. For more information, see OpenText
Intelligent Capture - Scripting Guide
(ECPCORE-PSC).
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2.3.6 Collecting Statistics
Statistics of two kinds are logged: operator performance statistics and classification
statistics.

Operator Performance Statistics

To collect performance statistics, the Identification step needs to be set up
accordingly. By default, performance statistics is not collected.
Operator performance statistics is intended for end-user reporting purposes. The
administrator can use it to track the operator productivity, particularly:

• The time spent per image (with the document type and the page template ID)

• The typing speed when indexing fields (keys per second)

• The number of manually classified documents and pages

Statistics on operator performance is collected in the Intelligent Capture database
tables:

Data Database Table Description

Template Tbl_ StatTemplate Stores information about the
pages processed by the
Identification module. You
can use this data to improve
extraction results for a
particular page template.
Information is divided by
process to enable you to
organize your data by line of
business in cases where
templates are shared.

Document Type Tbl_StatDocumentType Stores information about the
documents processed by the
Identification module. You
can use this data to
determine which document
types take the longest time to
process or have high
reclassification rates.
Information is divided by
process to enable you to
organize your data by line of
business in cases where
templates are shared.
Capturing character counts
enables accuracy
measurement by calculating
the percent of characters that
were changed.
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Data Database Table Description

Field Tbl_FieldStats Stores information about the
fields changed in
Identification; records are
created only for fields that
the operator changes. You
can use this data to
determine which fields take
the longest time to process or
have high data correction
rates. Capturing character
counts enables accuracy
measurement by calculating
the percent of characters that
were changed.

Note: These tables are updated by other modules as well. Each running
module creates new records in the three reports tables as needed, but no less
frequently than once per hour. The cumulative statistics for a given date and
hour are computed by aggregating all rows for that time. To learn more about
these tables, see OpenText Intelligent Capture - Administration Guide (ECPCORE-
AON).

Each table contains three fields (ReportTag1, ReportTag2, and ReportTag3) that
can used to further divide the statistical data according to business needs.
Identification exposes three IA values with the same names to let you pass string
values to the database tables.

Classification Statistics

Classification statistics is collected for Production Auto-Learning to improve
automatic template-based page classification. This statistics is written to the
PageDataXml IA value in the following data format:
<Page>
ClassificationTemplateID = Integer
ClassificationEditTemplateId = Integer
</Page>

Template ID set to “-1” indicates a page that has not been classified.
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2.4 Setting Up Completion
These topics describe how to set up the Completion module.

2.4.1 Configuring Operator View and Workflow for Efficiency
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Table 2-6: Completion Setup: View and Navigation Settings

Element Description

View mode Define the layout displayed to the operator
at launch. Values:

• Image and Form: Both the Page View
and Form panels are displayed and all the
menu items for Image Only and Form
Only.

• Image Only: Only the Page View panel is
displayed. The following menu items are
enabled:

– Page > Zoom In

– Page > Zoom Out

– Page > Default Zoom for Each Page

– Page > Pan Up

– Page > Pan Down

– Page > Pan Left

– Page > Pan Right

– Page > Auto Pan

– View > Form on Right and View >
Form on Bottom

In other view modes these menu items
are hidden. The behavior of the View
> Form on Right/Form on Bottom
menu option (available or grayed out)
is defined in the document type of the
currently processed document:

○ If the Default Form Position
document type setting specifies the
User Choice option, the menu
option is available.

The operator can re-dock the Form
panel to the bottom or to the right
edge of the main window. The
selected layout is saved in the user
preferences.

○ If the Default Form Position
document type setting specifies the
Bottom or Right option, the menu
option is grayed out.

• Form Only: Only the Form panel is
displayed. The Documents panel
displays the list of documents; however,
individual pages are not displayed.

The following menu items are displayed:

– Document > Choose Type
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Element Description
– View > Page List

– View > Summary

Work level Specify the work items that will be displayed
to the operator, such as flags, fields that
require manual confirmation, and validation
errors. Options: Manual, Character, Field,
Document. See “Setting the Work Level”
on page 41 for more detail.

Note: If the View mode setting is set to
Image Only, Manual is the only
possible selection.

Show manual confirmation Select this option to display as work items all
fields that require manual confirmation.

Intra-document page navigation Select this option to limit the shortcut
navigation between pages in the Documents
panel by the current document. The operator
cannot navigate to the next page if it starts
the next document or closes the preceding
document.

When disabled, the operator can navigate
through all pages of all documents in the
Documents panel using the arrow buttons or
key combinations CTRL+SHIFT+J (previous
page) and CTRL+SHIFT+K (next page).

Chapter 2   Setting Up the Modules

38 OpenText™ Intelligent Capture ECPCORE220300-CCV-EN-01



Element Description

Auto-advance to next document Select this option to let the operator
automatically advance to the next document
after all work items in the current documents
have been processed.

If selected:

• By default, a prompt dialog box is
displayed before proceeding to the next
document. The operator can allow or
suppress this prompt using the View >
Prompt at > End of Document menu
option. This setting is saved in the user
preferences.

• If the current document is the last
document in the task, the behavior is
defined by the Auto-advance to next task
setting.

If not selected, the operator stays in the
current document after all pages have been
done. The View > Prompt at > End of
Document menu option is not available.

Note: This option applies if
Completion is triggered on the Folder
level (level 2) or higher.
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Element Description

Auto-advance to next task Select this option to let the operator
automatically (without a prompt) get the
next task after the current one is completed.
If the current task still has work to be done,
then the focus stays in the current field.

If selected:

• By default, a prompt dialog box is
displayed before proceeding to the next
task. The operator can allow or suppress
this prompt using the View > Prompt at >
End of Task menu option. This setting is
saved in the user preferences.

• If the task includes multiple documents,
the Auto-advance to next document
option must be enabled; otherwise, the
operator stays in the current task.

• However, the Waiting for tasks from the
batch: <batch_name> dialog box is still
displayed. To automatically close this
dialog box after a specified number of
seconds and return to the Get Work
window, in %appdata%\Local\Emc\
InputAccel\Capture\UserPref
\<username>_CPDSKTOP, set the
following parameter:

TaskWaitScreenTimeout=<seconds>

where <seconds> is an integer that
represents the number of seconds to wait.

If not selected, the operator stays in the
current task after it is completed. The View >
Prompt at > End of Task menu option is not
available. The operator must finish the task
manually by pressing F10.

Show document type change prompt Select this option to display the prompt
when the operator picks a document type to
be applied to a document.

If not selected, the prompt dialog is
suppressed.
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Element Description

Display image snippets Select this option to display a small image
snippet near the focused field in the Form
panel. The snippet shows the image area
from which the value was extracted into the
selected field. Image snippets help the
operator validate and manually correct
extracted fields quickly, without searching
around the image.

When this option is selected, the operator can
enable or disable image snippets using the
View > Image Snippets menu command.

Notes
• View mode must be set to Image

and Form, or Form only.
• Image snippets are displayed for

document fields whose values were
extracted from the image by the
Extraction module. If you reassign
any document field with a different
value at runtime (in scripting or in
the CaptureFlow chart), the field's
extraction zone is deleted from the
document data. When the document
gets to the Completion step, the
operator cannot see the image
snippet for this reassigned field.

Related Topics:

“Setting the Work Level” on page 41

“Example: Setting View and Navigation for Particular Use Cases” on page 43

2.4.1.1 Setting the Work Level

In terms of operator activities, work is a task (part of a batch) received by the
operator from the server. Every work includes work items that the operator must
address to complete the task. Work items include flags, fields that require manual
confirmation, and validation errors.

Completion can be set up to limit work items displayed to the operator by a
particular work level, as described in the following table. This table describes the
types of work items to be corrected for each piece of work based on the work level
defined during Completion setup. The first column identifies the work level, the
second column identifies the validation errors the operator sees, and the third
column identifies the types of flags to be processed.
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Table 2-7: Work Levels

Work Level Work items displayed to the operator

Validation errors Fields for manual
confirmation (if the
Show manual
confirmation option
is enabled)

Flags (if the Flag
pages and
documents option
is enabled)

Manual

(The operator enters
data in the fields
manually)

None All fields are work
items which are
displayed regardless
of the Show manual
confirmation option
and even if the field
Manual
Confirmation
property is set to Do
Not Confirm in the
document type.

Field and page flags

Character Validation errors for
bad and low-
confidence characters
(returned by OCR)

Displayed based on
the field Manual
Confirmation
property value.

Field- and page-level
flags

Field • Validation errors
for bad and low-
confidence
characters
(returned by
OCR)

• Validation errors
for fields, such as
an incorrect date
format

• Failed field-level
validation rules.
Any rule that has
only one
associated
(dependent) field
is considered a
field-level rule.

Displayed based on
the field Manual
Confirmation
property value.

Field- and page-level
flags
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Work Level Work items displayed to the operator

Validation errors Fields for manual
confirmation (if the
Show manual
confirmation option
is enabled)

Flags (if the Flag
pages and
documents option
is enabled)

Document • Validation errors
for bad and low-
confidence
characters
(returned by
OCR), fields, and
documents.

• Validation errors
for fields, such as
an incorrect date
format

• Failed document-
level validation
rules

Displayed based on
the field Manual
Confirmation
property value.

Field, page, and
document flags

2.4.1.2 Example: Setting View and Navigation for Particular Use Cases

The following table illustrates how to set up the View and Navigation settings
based on different business use cases. Only settings that affect the work item count
are described.
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Table 2-8: Setup Options Based on Business Use Case

Based on your business need... Set up Completion as follows...

Use
Case

Operator
needs
to...

Notes Will low-
confiden
ce
characte
rs show?

Work
Level

Show
Form

Show
Manual
Confirma
tion

Flag
Pages
and
Docume
nts

High-
speed
indexing

Navigate
through
each field
(every
field is
work).
Work is
finished
when the
operator
has either
populate
d or
confirme
d every
field.

No OCR No Manual Yes N/A Yes or No

Image
quality
assurance

Look at
each page
to spot
poor-
quality
images,
then flag
those
pages.
Work
consists
solely of
setting or
removing
flags.

No OCR

No
indexing

No Manual No N/A Yes

Manual
classificat
ion,
document
assembly

Find the
first page,
separate
the
document
, choose
the
document
type, and
enter or
validate
key
fields.

No OCR

No prior
indexing

Data
entry
form has
few fields

No
(because
no OCR)

Field Yes Yes or No Yes or No
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Based on your business need... Set up Completion as follows...

Use
Case

Operator
needs
to...

Notes Will low-
confiden
ce
characte
rs show?

Work
Level

Show
Form

Show
Manual
Confirma
tion

Flag
Pages
and
Docume
nts

High-
speed
character
repair

Primarily
fix
characters
. If the
first page
contains
bad
characters
, flag the
document
and go to
the next
document
. If the
middle
page
contains
bad
characters
, split the
document
just
before the
bad page,
flag the
new
document
, and go
to the
next
document
.

OCR was
done,
pages
separated
; may
have
separatio
n errors

Data
entry
form may
have
many
fields (10
or more)

Yes Character Yes Yes or No Yes
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Based on your business need... Set up Completion as follows...

Use
Case

Operator
needs
to...

Notes Will low-
confiden
ce
characte
rs show?

Work
Level

Show
Form

Show
Manual
Confirma
tion

Flag
Pages
and
Docume
nts

Field
validatio
n

Navigate
through
incorrectl
y
populate
d fields.
Ensure
that the
data in
the fields
is the
same as
on the
image.

OCR is
usually
done, or
prior
indexing
was done.
Certain
fields
were
already
entered.
Character
repair
may
already
be done.

Data
entry
form may
have
many
fields (10
or more)

Yes Field Yes Yes or No Yes or No

Validate
business
rules

Perform
internal
validatio
n checks,
for
example,
the sum
of the
subtotals
does not
equal the
total.

Same as
field
validatio
n

Yes Documen
t

Yes Yes or No Yes or No

Related Topics:

“Configuring Operator View and Workflow for Efficiency” on page 36

Chapter 2   Setting Up the Modules

46 OpenText™ Intelligent Capture ECPCORE220300-CCV-EN-01



2.4.2 Enabling the Operator to Perform Certain Operations
You can enable operators to perform certain operations.

Table 2-9: Completion Setup: Permissions

Element Description

Edit fields Select this option to allow the operator to
edit text in the data entry fields.

Abandon changes Select this option to allow the operator to
abandon changes through a prompt dialog if
the task is canceled. If this option is not
selected, the canceled task returns to the
server with all changes saved; no prompt is
displayed.

Edit images Select this option to allow the operator to
rotate images. Page > Rotate is enabled.

Annotate images Select this option to allow the operator to
annotate images and to edit and remove
annotations added to images prior to the
Completion step. Page > Annotations is
enabled. View mode must be set to Image
and Form or Image Only.

If not selected, the Annotations palette is
unavailable. The operator cannot apply, edit,
or remove annotations.

Note: Irrespective of this option, the
operator can always see annotations on
images in the Page View panel and on
page thumbnails in the Documents
panel.

Copy pages Select this option to allow the operator to
copy and paste pages in the Documents
panel.

Note: This option applies if
Completion is triggered on or above
the Document level (level 1).

Copy documents Select this option to allow the operator to
copy and paste documents in the Documents
panel.

Note: This option applies if
Completion is triggered on or above
the Folder level (level 2).
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Element Description

Move pages Select this option to allow the operator to cut
and paste pages within the current document
and between documents in the Documents
panel.

Note: This option applies if
Completion is triggered on or above
the Document level (level 1).

Move documents Select this option to allow the operator to cut
and paste documents within the current
folder and between folders in the
Documents panel.

Note: This option applies if
Completion is triggered on or above
the Folder level (level 2).

Delete pages Select this option to allow the operator to
delete unnecessary pages from documents in
the Documents panel.

Note: This option applies if
Completion is triggered on or above
the Document level (level 1).

Delete documents Select this option to allow the operator to
delete unnecessary documents (with all
pages) in the Documents panel.

Note: This option applies if
Completion is triggered on or above
the Folder level (level 2).

Delete folders Select this option to allow the operator to
delete unnecessary folders (with all
documents) in the Documents panel.

Note: This option applies if
Completion is triggered on or above
the Stack level (level 3).

Print pages Select this option to allow the operator to
print pages and documents. Document >
Print is enabled. If not selected, printing is
disabled.

Note: View mode must be set to
Image and Form or Form Only.
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Element Description

Flag pages and documents Select this option to allow the operator to flag
pages and documents. If not selected,
flagging is disabled. Document > Flag is
enabled.

Note: View mode must be set to
Image and Form or Form Only.

Allowed document types Click the <n> options link (and Document >
Choose Type) to populate the list of
document types. The operator will be able to
assign a different document type from this
list to any document during validation.
Values:

• Leave the default value (*) to display all
document types available on the server.

• Specify the document type names to be
displayed to the operator. Add one
document type per line, pressing ENTER
to start a new line.

Use the wildcard (*) to add a group of
document types. For example, Invoice*
will result in all document types that start
with Invoice. If a single document type
such as Invoice* is defined, but no
document types matching that filter exist,
then the menu option is hidden.

• Clear the list to leave the pick list empty.
The operator will not be able to change
the document type.

Note: View mode must be set to
Image and Form or Form Only.

Press CTRL+ENTER to close the edit box.

Note: Alternatively, the list of
document types can be passed to the
step's AllowedDocTypes IA value. In
production, the assigned IA value will
take precedence over the setting
specified during step setup.
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Element Description

Organize documents Select this option to allow the operator to
create empty documents and split and merge
documents in the Documents panel. The
following menu items are enabled:

• Document>New Document

• Document>New Empty Document

• Document>Merge Document

If not selected, these operations are not
allowed.

Show batch tree levels up to level Select this option to allow the operator to
hide nodes above the specified batch level in
the Documents panel. Options: levels 2 to 6.

Allow organizing folders up to level Select this option to allow the operator to
merge, split, and create nodes in the
Documents panel on and above the selected
level. The following menu items are enabled:

• Document>Split>Split Folder

• Document>Merge>Merge Folder

Values:

• Levels 2 to 6

• None: Disables merging, splitting, and
creating nodes above the Document level
(level 1).

2.4.3 Defining the Available Flagging Reasons
Specify the flagging reasons that will be available to the operator. Completion
provides default flagging reasons for fields, pages, and documents to cover the most
typical situations when flagging may be needed. Depending on your business needs,
you can add more flagging reasons to each set of flags, remove existing flags, or
remove all flags.

All flagging reasons can be specified in the Flag reasons for fields, Flag reasons for
pages, and Flag reasons for documents lists. To specify a flagging reason, use the
following format:

<Display name> (<InternalName>[:<shortcutChar>])

• The display name is the descriptive flagging reason to be displayed to the
operator.

• The internal name is intended for scripting and regular expressions.

• The shortcut key (one character) is optional.
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Example: Too Dark (TooDark) or Too Dark (TooDark:D) (with a shortcut key
specified)

If Completion defines multiple flagging reasons, the operator sees the Reason for
Flagging dialog at any attempt to set or edit flags. If you define only one flag for
fields, or pages, or documents, the respective object can be flagged with a single
command or a sequence of keys; the Reason for Flagging dialog is not displayed.
For instance, if you delete all default flags and add a single Rejected flag for
documents, the operator will be able to set and remove it with a single command,
without posting the Reason for Flagging dialog.

Recommendations and Use Cases

• Unless there is a specific reason to do otherwise, all Identification and
Completion steps in a CaptureFlow should be configured with identical page
and document flagging reasons and format. When flagged pages and documents
are routed to other steps, flags are transferred in values PageFlag and DocFlag
as sequences of internal names. The display names and the shortcut characters
are not passed to the next step. If the Reason for Flagging dialog of a given
Identification or Completion step receives the internal name of the flag and no
definition, the operator will see that internal name; the shortcut will not be
provided.

• If user-defined flags or flags for internal operator messages are required,
consider enabling and instructing operators to use annotations.

• A task will complete even if it is flagged with errors. To ensure all flagged errors
are fixed before the task is complete, route a task back to a supervisor or operator
for completion when the PageStatus.RemainingWork IA value is greater than
zero.

Completion Setup: Flagging Settings

Flag reasons for fields
Click the <N> Options link to edit the field flagging reasons that will be
displayed to the operator in the Reason for Flagging dialog.

Default flagging reasons for fields include:

• Value does not exist in database(NotExist)

• Information is unreadable(Unreadable)

• Value conflicts with other data(DataConflict)

Add each reason in a new line. The format of the flagging reason specification is
described above. Add all flagging reasons in the same format – with or without
a shortcut. If all flagging reasons are defined without shortcuts, the default
shortcuts will be generated at runtime. If shortcuts are defined for particular
(not all) flagging reasons, only these shortcuts will be generated.
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Note: You can override this setting for a step using the
AllowedFieldFlags IA value. In production, the assigned IA value will
take precedence over the setting specified during step setup.

Flag reasons for pages
Click the <N> Options link to edit the page flagging reasons that will be
displayed to the operator in the Reason for Flagging dialog.

Default flagging reasons for pages include:

• Too light(TooLight)

• Too dark(TooDark)

• Noise(Noise)

• Bent corner(BentCorner)

• Skewed(Skewed)

• Delete(Delete)

• Wrong image(WrongImage)

• Double feed(DoubleFeed)

Add each reason in a new line. The format of the flagging reason specification is
described above. Add all flagging reasons in the same format – with or without
a shortcut.

Note: You can override this setting for a step using the AllowedPageFlags
IA value. In production, the assigned IA value will take precedence over
the setting specified during step setup.

Flag reasons for documents
Click the <N> Options link to edit the document flagging reasons that will be
displayed to the operator in the Reason for Flagging dialog.

Default flagging reasons for documents include:

• Research is needed(Research)

• Pages are missing(MissingPages)

• Rescan whole document(RescanDocument)

Add each reason in a new line. The format of the flagging reason specification is
described above. Add all flagging reasons in the same format – with or without
a shortcut.

Note: You can override this setting for a step using the AllowedDocFlags
IA value. In production, the assigned IA value will take precedence over
the setting specified during step setup.
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2.4.4 Options for IA Values, Abandoning Changes, Collecting
Statistics, and Scripting
Configure advanced Completion settings, including passing document data to the
next steps, collecting statistics, and other options.

Completion Setup: Advanced Settings

Output IA value destination
Specify output of document fields into flattened IA values in addition to the
original UIM data structure. Options:

• (Do not write to IA values): Do not flatten document fields into IA values.
Document fields are output in their original UIM structure only. This option
works if output is further processed by a module that directly supports UIM
data, such as Extraction, Identification, or Standard Export.

• <Step name>: Select the step into whose values the document data will be
flattened.

Note: The destination IA values must be pre-created. If all document
fields cannot be known in advance, consider using the Output dynamic
values option to enhance data flattening with dynamically created
values.

Output IA value level
If data flattening is enabled in the Output IA value destination setting, expand
the drop-down list and select the level to which Completion will output the
flattened document data:

• Document Only: Default. Select to output all document fields to IA values of
level 1 (Document level), irrespective of the field levels specified in the
document type.

• Field Index Level Only: Select to output document fields to IA values in
accordance with the Index Level specified in the document type for each
field.

• Document And Field Index Level: Select to use both approaches to output
document data. If the document type specifies the above-document level for
a field, such a field will be output to a document-level IA value and to
another IA value of the level specified in the Index Level attribute.

Note: When outputting to the index level, the Completion module can
overwrite the preceding outputs with blank values.

Allow import higher level values
Select this option to propagate document data between tasks where the index
level of the fields is higher than 1 (Document level). This option requires the
Output IA value destination setting to enable flattening document data to
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values above the document level. Before loading a new task, data is propagated
in accordance with the selected output destination and at the index level
specified for this field in the document type.

For example, if the batch forms several tasks on the validation step, the first
operator sets value <A> (level above 1) and uploads it to the batch, and the next
operators receive tasks with this value <A> already set (exported from the batch)
and populated to the document field.

Note: When using custom values as a destination, make sure that the step
has the input UimDataImportMode IA value assigned properly to allow
for binding index values higher that task level.

Output array field
If data flattening is enabled in the Output IA value destination setting, expand
the drop-down list and specify how array (table) fields will be output:

• Value Per Row: Output each array item as a separate IA value with the
<FieldName>_<row #> name where the row number starts at 1.

• Value Per Array Field: Output each table field (all rows) as a single
<CR><LF> delimited string value with the <FieldName> name. The last item
in the string is not followed by the delimiter.

In both cases, the number of table records is output to IA value
<TableName>_count.

For example, a Fruits table includes the following fields and content:

ID Description

1 Orange

2 Apple

If you select the Value Per Row option, the table content will be output as
follows:

• Id_1=“1”

• Description_1=“Orange”

• Id_2=“2”

• Description_2=“Apple”

• Fruits_count=“2”

If you select the Value Per Array Field option, the table content will be output
as follows:

• Id=“1<CR><LF>2”

• Description=“Apple<CR><LF>Orange”

• Fruits_count=“2”
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Save values when structure changes
This setting configures the ability of the operator to cancel the task with the
Abandon changes option in the prompt dialog box.

Note: This setting applies if the Abandon changes setting enables posting
a prompt. Otherwise, the task returns to the server with all changes saved
in silent mode.

Select this option to let the operator cancel the task with the Abandon changes
option only if there were no task changes saved on the server immediately.
These changes include deleting or moving pages, splitting, merging, cutting, or
copying nodes, rotating or annotating pages. If any of those changes took place,
the operator has no option to abandon changes. The prompt will show the
notification about saving all changes; the Abandon changed option will be
hidden.

If not selected, the operator always has an option to cancel the task with the
Abandon changes option. If any of the task changes were saved on the server
immediately, they are already applied to the batch and cannot be abandoned.
Other changes such as indexed fields or flagging are abandoned.

Output dynamic values
If data flattening is enabled in the Output IA Value Destination setting, select
this option to automatically create dynamic values for fields that do not have
pre-created IA values.

If not selected, Completion flattens document fields into matching IA values (if
such are found) and skips fields where no matching IA value is detected.

If data flattening is disabled in the Output IA Value Destination setting, this
option is grayed out.

Collect document type and templates statistics
Select this option to log Completion statistics in the Template and
DocumentType tables in the Intelligent Capture database. Statistics, which are
used in reports, are logged for document types and templates applied by the
operator.

Note: If the Intelligent Capture database is installed on SQL Server Express
or an internal database is used, this option is ignored and Completion
statistics is not logged.

Collect field statistics
Select this option to log Completion statistics in the Fields table in the
Intelligent Capture database. Statistics. which are used in reports, are logged for
the data entry fields updated by the operator.

Note: If the Intelligent Capture database is installed on SQL Server Express
or an internal database is used, this option is ignored and Completion
statistics is not logged.
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Custom value
Enter an input string to be passed in to document type scripting. The format of
this string is defined in scripting. For more information, see OpenText Intelligent
Capture - Scripting Guide (ECPCORE-PSC).

Script task class name
This setting is used by document type scripting.

Specify the name of the .NET class for each type of a task derived from
UimScriptTask. If this class is not specified in this setting, the global events in
UimScriptMainCore will be invoked. For more information, see OpenText
Intelligent Capture - Scripting Guide (ECPCORE-PSC).

2.4.5 Collecting Document Type Statistics
Both the Extraction and Completion modules provide statistics. These statistics,
which pertain to production data, can help you identify issues that affect
productivity. You can:

• Measure operator productivity.

• Find classification problems: Identify pages for which classification failed or
documents for which the document type was changed.

• Find extraction problems: Identify fields that contained low-confidence
characters or for which the value was changed after extraction.

• Find throughput bottlenecks: Identify steps where extraction or validation were
slow.

You specify whether statistical data is collected as part of the step configuration
settings in each process. The Extraction module provides Setting Up Extraction.
Completion provides Options for IA Values, Abandoning Changes, Collecting
Statistics, and Scripting.

2.4.5.1 Where Data is Stored

Statistical data is stored in the following tables:

Template
Stores information about the pages processed by the Extraction module. You can
use this data to improve extraction results for a particular page template.
Information is divided by process to enable you to organize your data by line of
business in cases where templates are shared.

Document Type
Stores information about the documents processed by the Extraction module
and Completion. You can use this data to determine which document types take
the longest time to process or have high reclassification rates. Information is
divided by process to enable you to organize your data by line of business in
cases where templates are shared. Capturing character counts enables accuracy
measurement by calculating the percent of characters that were changed.
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Field
Stores information about the fields changed in Completion; records are created
only for fields that the operator changes. You can use this data to determine
which fields take the longest time to process or have high data correction rates.
Capturing character counts enables accuracy measurement by calculating the
percent of characters that were changed.

Each table contains three tags (ReportTag1, ReportTag2, and ReportTag3) that can
be used to further divide the statistical data according to business needs. You can
use these tags to capture separate data in cases where capture services are shared
across an organization. For example, you could organize the statistics by functional
area by setting ReportTag1 to the functional area for each task, such as Accounting
for one task and Sales for a second task. Another example might be to organize by
geographical region such as North America versus Europe. You could group the
statistics by these tags to show operator productivity for each functional area or
geographical region.

Note: The string values you specify for these tags are written to the database
exactly as entered. No processing is performed on the values. The tags are set
by the IA process as task-level values with the same name.

Use these tags only when you need to further break down statistical data.
Capturing additional, unused information increases the number of records in
the database unnecessarily.

For information about the reports tables, see OpenText Intelligent Capture -
Administration Guide (ECPCORE-AON).

2.4.5.2 How Data is Captured

Each running module creates new records in the three reports tables (Template,
Document Type, and Field) as needed, but no less frequently than one per hour. The
cumulative statistics for a given date and hour are computed by aggregating all
rows for that time.

Example: The number of pages processed by Extraction on 1/23/2012 between 10:00 and 11:00
is the total of all records where the Date is set to 1/23/2012 10:00.
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Chapter 3

Tasks

Unless otherwise indicated the tasks outlined in this section apply to both
Completion and Identification.

3.1 High-Level Procedures
In addition to the standard menu items, you can also perform actions as follows.

Keyboard shortcuts
Keyboard shortcuts provide a high-speed alternative to using the mouse and are
often the most efficient way to perform an action. Default shortcut keys are
provided for operation without a mouse.

Your administrator might have changed the default keyboard mappings.
Contact your administrator for a list of keyboard shortcuts. For a consolidated
list of default shortcut keys, see “Keyboard Shortcuts” on page 131.

Right-clicking
Right-clicking is also known as a context menu.

Right-click an item and select from the list of actions that are valid for the item.

3.1.1 Identification

1. To start Identification, click the Identification icon ( ) and then log in and
get work. For more information, see “Getting Batches” on page 62.

Note: For your user account information, see your administrator.

2. Perform the following actions as required to complete the task:

Note: Depending on how your administrator set up Identification, you
might not have to assign a template to every page to finish the task. For
example, you might be able to finish a task even if it has pages without
assigned templates or pages (including whole documents) that have been
flagged.

• Assign templates to pages.

– If a document was not assigned a document type or template code
automatically, assign it manually. For more information, see
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“Assembling Documents Automatically (Identification Only)”
on page 69.

– Assign (or reassign) a template to the page or assign the last used
template to selected pages where possible. For more information, see
“Assigning Templates (Identification Only)” on page 78.

– Resolve classification conflicts. For more information, see “Resolving
Classification Conflicts (Identification Only)” on page 86.

• Flag documents, pages, or fields. For more information, see “Flagging
Documents, Pages, or Fields With Reasons” on page 104.

• Annotate pages. For more information, see “Annotating Pages With
Auxiliary Information” on page 108.

• Validate data. For more information, see “Validating Fields in Identification”
on page 88.

3. Finish the task, defer the task, or stop working.

For more information, see:

• “Finishing Tasks” on page 113

• “Deferring Tasks” on page 114

• “Stopping Work” on page 116

3.1.2 Completion
A task usually consists of multiple pages in several documents, all of which need to
be checked; however, a task could also consist of the following pages:

• A single page only.

• Documents in which only a subset of pages are available to be checked; that is,
pages that do not need to be checked have been filtered out.

In these cases, only the applicable panels and operations are available as follows:

• If a task consists of multiple pages in one or more documents, then all panels are
displayed. (This configuration is sometimes called the default mode.)

• If a task consists of a single page only (which is not contained within a
document), then only the Page View panel, the Reasons for Flagging panel, and
message bar are displayed; in addition, the Page View panel displays CURRENT
PAGE. (This configuration is sometimes called page mode.)

You should inspect the page and accept or reject it quickly.

The high-level steps for processing a task are as follows:

1. To start Completion, click  and then log in and get work.

Chapter 3   Tasks

60 OpenText™ Intelligent Capture ECPCORE220300-CCV-EN-01



For your user account information, see your administrator. For more
information, see “Getting Batches” on page 62.

2. Verify the image quality of each page.

You might also need to flag pages that have image quality issues.

For more information, see:

• “Zooming and Rotating Pages” on page 74

• “Flagging Documents, Pages, or Fields With Reasons” on page 104

• “Changing the Documents Panel Layout” on page 125

• “Shortcuts and Arrow Keys for Moving Around the Page” on page 142

3. Verify that the task structure is correct.

For example, make sure that documents include complete sets of pages, pages
are split into separate documents correctly, and the order of pages in each
document is correct. For more information, see “Reorganizing Folders,
Documents, and Pages” on page 62.

4. Validate the data in index fields and table fields.

For example, you might need to enter data manually (with rubberbanding),
change document types, flag fields that have issues, or annotate a page that has
field issues.

For more information, see:

• “Validating Fields” on page 89

• “Basic Rubberbanding” on page 103

• “Table Data” on page 92

• “Changing the Document Type” on page 101

• “Flagging Documents, Pages, or Fields With Reasons” on page 104

• “Annotating Pages With Auxiliary Information” on page 108

5. Finish the task, defer the task, or stop working.

For more information, see:

• “Finishing Tasks” on page 113

• “Deferring Tasks” on page 114

• “Stopping Work” on page 116
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3.2 Getting Batches
After logging in, the Get Work window is displayed and you select the work to
complete.

To get work:

1. Select one of the following:

• (All Batches): You receive tasks from all batches available for processing.

• <batch_name>: You receive tasks from the selected batch only. When selecting
a particular batch from the list:

– Consider taking a batch with the highest priority first.

– Notice the amount of the remaining tasks shown in the Tasks column
and select work accordingly.

Note: Other operators may receive tasks from the same batch as
well. In this case, you may see the Tasks column updated to show a
lower number of remaining tasks.

– Sort the list of batches by a column if necessary.

– Filter the list of batches by the batch name if necessary. Start typing a
batch name in the filter box to view the batch names that contain the
entered text. The filter is case-insensitive.

2. Click Get Work.

You can also filter the list of available batches by department as follows:

• To get work from any department, click the Select All button.

• To get work from a particular department, in Departments, select the required
checkbox.

• To get work that has no department assigned, in Departments, select the
(Unassigned) checkbox.

3.3 Reorganizing Folders, Documents, and Pages
When you receive a new multi-page task, consider verifying the task structure in the
Documents panel prior to validating document data or classifying pages. Make sure
that all documents include complete sets of pages, all pages are split into separate
documents correctly, and the order of pages in each document is correct.

Sometimes, documents in a task are not separated properly; for example, when any
document in the task combines pages that belong to two or more physical
documents. In this case, you can split and merge the documents and higher-level
nodes as appropriate to reflect their correct structure. Splitting is used to create a
document, or to insert a new folder or a higher-level node (at the desired level), and
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move the current content into it. Merging is used to move the content from a
document, or a folder, or a higher-level node (at the desired level) to the previous
document or folder, after which the emptied node is deleted from the batch.

Caution
All operations described in this section modify the batch structure. These
changes are saved to the server immediately and cannot be reverted. After
you perform any of these operations, the task cannot be returned to the
queue with Abandon changes. However, for splitting and merging, you
could subsequently perform the opposite merge or split operation to go
back to the original structure.

Notes

• Some operations must be enabled by your administrator.

• In Completion, if a task includes filtered pages (also known as page filtering
mode), then you cannot modify (including moving and deleting pages) the
task structure. A document with filtered pages has the following icon:

3.3.1 Folders and Higher-Level Nodes
In the Documents pane, you can perform the following actions on folders and nodes
higher than the folder level:

Notes

• Unless otherwise indicated, the term, folder, also includes nodes higher than
the folder level. Nodes higher than the folder level are only available in
Identification.

• If an operation is not available, then you do not have the appropriate
permissions. See your administrator.

• In Completion, if a task includes filtered pages (also known as page filtering
mode), then you cannot modify (including moving and deleting pages) the
task structure.

Icon/Menu Item Description

Edit > Copy Makes copies of the selected folders and
moves them to the Clipboard.
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Icon/Menu Item Description

Edit > Cut Cuts the selected folders from the batch and
copies them to the Clipboard.

Tip: You can also perform a cut and
paste action by dragging and dropping
a folder with the mouse.

Caution
You can move folders within
current task only. If you cut a
folder and then finish the task and
get the next task, then attempting
to insert the cut folders results in a
fatal error and the cut elements
with all data are lost.

Edit > Paste Pastes folders after the selected folder.

Splits the folder at the selected document in
the current folder as follows:

• The selected document and all of the
documents following it are placed into a
new folder, which is created after the
current folder.

• All documents preceding the selected
document are kept in the current folder.

(Identification only) When you split nodes
above the folder level, all required nodes are
created. For instance, splitting at level 4
creates a new node at level 4 after the current
one in which you selected a document. This
new level 4 node includes: a new level 3
node, a new folder (that is, a level 2 node)
inside, and inside it the document at which
you split and all of the following documents
from the current folder.

Note: If the selected document is the
first document in the current folder,
then a new empty folder is created
before the current folder (which is left
unchanged).

Adds the documents of the selected folder to
the preceding folder after the last document
in the preceding folder; the current folder is
deleted.

You select a folder by selecting either the
folder node or a document in the folder.
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Icon/Menu Item Description

Edit > Delete Deletes the selected folder.

Caution
After you delete a page, document,
or folder, the modified batch
structure is saved to the server
immediately and you cannot revert
the change.

3.3.2 Documents
In the Documents pane, you can perform the following actions on documents:

Notes

• If an operation is not available, then you do not have the appropriate
permissions. See your administrator.

• In Completion, if a task includes filtered pages, then you cannot modify
(including moving and deleting pages) the task structure.

Icon/Menu Item Description

Edit > Copy Makes copies of the selected documents and
moves them to the Clipboard.

Edit > Cut Cuts the selected documents from the batch
and copies them to the Clipboard.

Caution
You can move pages and
documents within current task
only. If you cut a page or a
document and then finish the task
and get the next task, then
attempting to insert the cut page or
document results in a fatal error
and the cut elements with all data
are lost.

Edit > Paste To paste documents after another document,
select the document.

To paste documents at the beginning of
another document, select the document.
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Icon/Menu Item Description

Document > New Empty Document

Inserts an empty document as follows:

• If the selected item is a document, then an
empty document is inserted before the
selected document.

• If the selected item is a folder, then an
empty document is inserted as the first
document in the selected folder.

Notes
• If configured by your administrator,

empty documents and folders are
highlighted in a frame of a different
color. If you see highlighted empty
nodes, no special action is required.
A task with empty nodes is not
corrupted and can be successfully
finished.

• In Identification, if you switch the
Documents panel to the page list
mode, the Binding field displayed
and you cannot insert empty
documents and split/merge the
existing documents. Documents are
split and merged automatically
based on the binding field or
separator template, as described in
“Assembling Documents
Automatically (Identification Only)”
on page 69. However, you can split
and merge nodes above the
document level if you have
respective permission granted.

Tip: You might need a special empty
document to collect pages that do not
belong to any other document.
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Icon/Menu Item Description

Document > New Document

Creates a new document by splitting the
document at the selected page in the current
document as follows:

• All pages preceding the selected page are
kept in the current document.

• The selected page and all of the pages
following it are placed into a new
document (which follows the current
document).

Note: The new document has the same
document type as the current
document; however, only the current
document has the original field data.
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Icon/Menu Item Description

Adds the pages of the selected document to
the preceding document after the preceding
document's last page.

Notes
• You select a document by selecting

either the document node or a page
in the document.

• You can merge only documents that
are in the same folder.

Merging is useful when two or more
documents in the task contain pages that
actually make up a single document, such as
a purchase order and its attachment pages.
You can also use merge to revert the split
operation.

Caution
• In Completion, after merging,

only the first document will
have the original data. The data
for the second document is
discarded. The changes are
committed to the server
immediately and cannot be
reverted. If you apply the split
operation to revert the merge,
the data lost after the previous
merge will not be restored.

• In Identification, if you merge
documents that were assigned
a document type or code before
the operation, the following
changes are committed to the
server immediately and cannot
be reverted:

– After merging, only the first
document will have the
original classification data.
The data for the second
document is discarded and
only the data for the first
document is kept.

– If you merge documents in
auto-assignment mode, all
moved pages are
reclassified with new
templates as specified by the
assigned document type or
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Icon/Menu Item Description
code; pages classified with
new templates get new
index fields. If you apply
the split operation to revert
the merge, the previous
classification data for the
moved pages will not be
restored.

Edit > Delete Deletes the selected document.

Caution
After you delete a page, document,
or folder, the modified batch
structure is saved to the server
immediately and cannot be
reverted.

Note: If configured by your
administrator, empty documents and
folders are highlighted in a frame of a
different color. If you see highlighted
empty nodes, no special action is
required. A task with empty nodes is
not corrupted and can be successfully
finished.

3.3.2.1 Assembling Documents Automatically (Identification Only)

Some operations that you perform during page classification can reassemble the
document automatically.

After the documents are split or merged automatically based on a separator or field
binding, you can correct the structure of the task manually. For instance, you can
move pages between documents, or split and merge documents as needed.

Note: If field binding is enabled, then you cannot split and merge documents
nor add empty documents.
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Table 3-1: Assembling Documents Automatically

Use Case Description

Case 1: The template contains a binding field The purpose of the binding field is to assist
in keeping expected pages together in the
same document. For example, if an invoice
number is specified as a binding field value
and then you change the invoice number of
the current document's first page to the same
number as the last page in the previous
document, then that first page would be split
from the current document and merged into
the previous document as the last page.

Note: The Documents panel (page list
mode) includes the Binding Field
column that shows the binding value
for each page.

To merge adjacent pages into the same
document, the pages must meet the
following merging criteria:

• Their templates have the same template
code.

• They have the same binding field values
or a blank value.

If one of the pages is an attachment (or
does not have a binding field), then the
binding field of the indexed page to
which the attachment (or page without a
binding field) is bound is evaluated.

Furthermore, all pages in the same document
must meet the aforementioned criteria.

Notes
• A page with a blank binding field

value acts as a wildcard and binds
with a page that has any binding
value, including another page that
has a blank value.

• A page without a binding field is
handled the same way as an
attachment.

• Attachments are pages that are not
indexed (and as such they cannot
have binding fields). Examples of
attachments are pictures of receipts
itemizing charges in an invoice. A
sequence of contiguous attachment
pages are considered to be a single
unit. This unit cannot be split and is
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Use Case Description
bound to an indexed page of the
document of which the attachments
were originally a part. The indexed
page to which the attachment
sequence is bound is the page that
precedes the sequence; however, if
the attachment sequence starts the
batch, then the bound page is the
one at the end of the sequence.

Attachments could be anywhere in a
document, including the middle.

• Separator pages take precedence
over binding field values. See “Case
3: A task includes classified
separator pages and field binding”
in this table.

If you change the current page's binding field
value to one that is different from the
previous or next page (in the same or
different documents), then one of the
following occurs:

• If the current page is the first page in the
document, then one of the following
occurs:

– If the previous page (that is, the last
page in the previous document) meets
the merging criteria, then the current
page is split from the current
document and merged with the
previous document.

– If the previous page does not meet the
criteria or there is no previous
document, then the current page is
split from the current document and
becomes the first page in a new
document.

• If the current page is the last page in the
document, then one of the following
occurs

– If the next page (that is, the first page
in the next document) meets the
merging criteria, then the current page
is split from the current document and
merged with the next document.

– If the next page does not meet the
merging criteria or there is no next
document, then the current page is
split from the current document and
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Use Case Description
becomes the first page in a new
document.

• If the current page is in the middle of the
document, then the current page and all
of the following ones are split from the
current document; the current page
becomes the first page of a new document
and the merging criteria are applied to
each of the following pages.

Case 2: A separator template is assigned or
unassigned

If you classify any page in a document using
a separator template, that is, a template with
the “separator” attribute, the document is
split at the separator page into two
documents. Similarly, if you replace the
separator template on the first page in a
document with a different template, the
document is merged with the previous
document (if one exists).

Note: Deleting a page with a separator
template does not result in merging.

Case 3: A task includes classified separator pages
and field binding

When a task includes classified separator
pages and field binding, separator-based
splitting and merging has a priority:

• If you assign a separator template to any
page in the task, that page starts a new
document.

• If you reassign a different template to a
classified separator page, the binding
rules apply.

3.3.3 Pages
If an operation is not available, then you do not have the appropriate permissions.
See your administrator.

In the Documents pane, you can perform the following actions on pages:

Note: In Completion, if a task includes filtered pages (also known as page
filtering mode), then you cannot modify (including moving and deleting pages)
the task structure.

Icon/Menu Item Description

Edit > Copy Makes copies of the selected pages and
moves them to the Clipboard.
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Icon/Menu Item Description

Edit > Cut Cuts the selected pages from the document
and copies them to the Clipboard.

You can also perform a cut and paste action
by dragging and dropping pages with the
mouse.

Caution
You can move pages and
documents within current task
only. If you cut a page or a
document and then finish the task
and get the next task, then
attempting to insert the cut page or
document results in a fatal error
and the cut elements with all data
are lost.

Edit > Paste To paste pages after another page, select the
page.

To paste pages at the beginning of a
document, select the document.

Note: New in 22.1, the following IA
Values continue to be available after
copying and can be pasted multiple
times:

• AnnotationComment

• Backside

• Image

• ImageType

• OcrDataCache

• PageDataXml

• PageFlag

• Rotation

• SourceNodeID

For more information, see “IA Values”
on page 165.
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Icon/Menu Item Description

Edit > Delete Deletes the selected pages.

You can select pages in different documents.

Caution
After you delete a page, document,
or folder, the modified batch
structure is saved to the server
immediately and cannot be
reverted.

3.4 Changing the Page View
When you select a page, the Page View panel displays the scanned image of this
page with the default scaling and original page orientation (portrait or landscape).
You can adjust the displayed image in the panel with the following operations.

3.4.1 Zooming and Rotating Pages

Note: An image saved after a PDF rotation, is not in PDF format. It is a JPEG
image contained in a PDF wrapper.

Action Icon/Tooltip Description

Fit the page height in the
pane

Fit Height

Fit the page height to the
viewing pane.

Fit page in the pane

Fit Page

Fit the page height and width
to the viewing pane.

Fit the page width in the
pane

Fit Width

Fit the page width to the
viewing pane.

Drag the image N/A Pan the image by dragging
the image with the cursor or
using the scrollbars.
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Action Icon/Tooltip Description

Automatically focus on a
field in the Page View pane
that corresponds to the
current field on the Form
panel (Completion) or Index
Fields panel (Identification) Auto Pan

Activates or deactivates
automatic panning.

For more information, see
“Automatic Panning”
on page 78.

Note: In Identification,
automatic panning is
not available for
information extraction
projects.

Open the image in a separate
window (which could be on
another monitor)

Pop Out

Pop out the page view into a
separate window (which
could be on another
monitor).

Note: Closing the
window also returns it
to the Page View pane.

Set default zoom The default zoom for the
Page View.

Click the triangle to select the
default zoom.

To deactivate or activate
default zoom, click the
magnifying glass.

You can also use Page >
Default Zoom for Each Page
and Page > Set Default
Zoom to.

Notes
• This default applies

to other tasks and in
other work sessions
as well as the current
one.

• If the default zoom is
not specified, then
the last used zoom
setting is used.

3.4. Changing the Page View

ECPCORE220300-CCV-EN-01 Desktop Client Guide: Identification and Completion 75



Action Icon/Tooltip Description

Zoom out/in Zoom the view in or out. You
can also select a specific
percentage for the view.

Tip: To zoom an image
quickly in 5%
increments, position
the cursor on the image
and press and hold
down CTRL and then
scroll the mouse wheel.
Zooming is centered on
the mouse cursor.

Rotate the image
counterclockwise 45 degrees

Rotate counterclockwise 45
degrees.

Caution
If an image has
highlighted image
zones, they are not
rotated with the
image and start
reflecting incorrect
data. Use
rubberbanding to
define new image
zones for index
fields, or populate
index fields with
correct data
manually.

Rotate the image clockwise
45 degrees

Rotate clockwise 45 degrees.

Rotate the image clockwise
180 degrees

Rotate 180 degrees clockwise.
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3.4.2 Zooming into the Image Area
In addition to the standard image zooming in the Page View panel, you can benefit
from zooming into the required image area. The zoomed part of the image appears
in the Page View panel in the full screen mode. During field indexing, the zoomed
area behaves similar to the original image. In particular, it displays the highlighted
zones for the selected fields and allows you to rubberband image values.

Based on your desired outcome, perform the steps in the following table:

Table 3-2: Zooming the Image Area

To Do This Perform These Steps

Zoom the selected image area to the full
screen

1. Draw a rectangular area on the image
with the mouse cursor, keeping SHIFT
and the secondary (right) mouse button
pressed.

2. Release the mouse button to view the
selected area zoomed to the full screen.

Move the zoomed area 1. Click inside the zoomed area.
2. Drag the zoomed area with the mouse,

keeping the primary mouse button
pressed, then release the mouse button.
Or, keep CTRL pressed and use the
arrow buttons to move the zoomed area:

Resize the zoomed area Put the mouse cursor over one of the four
edges or borders. Drag the corners or borders
of the zoomed area with the mouse.

Alternatively, resize the zoomed area using
the CTRL+PLUS and CTRL+MINUS key
combinations.

Minimize the zoomed area back to its actual
size

Double-click inside of the Page View panel
that displays the zoomed area in the full
screen mode.
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3.4.3 Automatic Panning
Automatic panning allows you to speed up the validation of index values in a
document as follows:

• When you jump into the populated field in the Form panel (Completion) or
Index Fields panel (Identification), the image is automatically panned to show
the image zone with the value displayed in that field. The focused image zone is
highlighted in color. Thus, you are focused to the value on the image every time
you select an indexed field in the panel.

• In Completion, when a document includes multiple pages, the fields in the form
can be populated from image zones located on different pages (images). When
you set focus on a field that has a zone on a different image, the application
switches to that image automatically.

Note: When you select a field that has no image zone, Auto Pan can
automatically select a different image that contains data related to the
currently selected field. This optional capability of Auto Pan is based on
field grouping. If the fields in the data entry form are not configured to
form groups, this capability is not available.

Related Topics:

“Shortcuts and Arrow Keys for Moving Around the Page” on page 142

3.5 Assigning Templates (Identification Only)

If the Template not assigned  status is displayed on a page, then you should
classify the page by assigning a template to it. Once a template is assigned to a page,
it changes to the Completed  status (and is shaded in green).

You can finish a task if all pages in the Documents panel are Completed or flagged
(if enabled by your administrator).

You classify pages as follows:

• Manual assignment: You assign a template to each page individually. Where
applicable, you can optimize the task processing by applying a template to a
group of pages.

• Auto-assign a sequence of templates: You process documents in which their
pages are known in their number and content. You can use this mode
permanently, or enable/disable it as an option for any document in a task.
Disabling the Auto-assign a sequence of templates mode switches you to
manual assignment. You can always manually change template assignment for
individual pages.
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Note: Auto-assigning templates does not apply to information extraction
projects.

3.5.1 Assigning a Template to a Page
In manual assignment mode, you need to manually assign a template to every
yellow (“classification needed”) page in the Documents panel. For each page, you
need to select an appropriate template from the Template List panel.

Depending on the application settings, Template List panel can display the
Template Name and Code columns, or the Code column only. In the first case, you
select templates by name. In the second case, the template names are hidden; you
select a group of templates by code, and the template that fits best is selected from
this group by Identification automatically.

Note: You cannot select multiple pages in the Documents list and assign them
all with a template selected from the Template List panel. However, if the
template list displays the Template Name column, Identification remembers
the name of the last used template. This template can be assigned to a group of
pages.

To assign a template to a page:

1. Select a page in the Documents panel.

To select multiple pages, click each one with the mouse, keeping CTRL or
SHIFT pressed.

Note: Assigning a template to multiple pages requires specific permission.

To help you select a template for a page, the Template List panel indicates the
best candidates marked with an icon:
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Table 3-3: Template Icons and Statuses

Icon Template status Description Recommended
steps

<confidence rate>% Recommended Indicates the
template with the
high confidence rate
(in %).

If a given page has
recommended
templates, the
Template List panel
shows the <N>
recommended
message.

1. Click the Show
recommended
button to show
only
recommended
templates and
hide the rest.

2. Click Show All
to remove the
filter.
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Icon Template status Description Recommended
steps

“Favorite” (“star”) Recently used Indicates the
recently used
template.
Identification
remembers up to
five recently used
templates in the
scope of the current
task.

You can sort the list
of templates to
show the most
recently used
templates on top,
ordered
alphabetically,
followed by the rest
of templates, also
ordered
alphabetically. If a
recommended
template becomes
recently used, it is
still marked with
the “confidence
rate” icon; however,
it appears on top as
a recently used
template.

Note: This
option is not
provided if
the Template
List panel
shows the
Code column
only.

1. To show the
recently used
templates on
top, expand the
Template List
panel settings
and select Most
recently used
first.

Note: This
filter can
be
activated
in the
applicatio
n settings,
in which
case you
will see
this option
selected
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Icon Template status Description Recommended
steps

automatic
ally.

2. Uncheck the
option to
remove the
filter.

“Checked” Assigned Indicates the
template assigned to
the currently
displayed page.

If you assign a
recommended or a
recently used
template, this
template changes its
icon to “checked”. If
you assign a
different template to
the page, the given
template gets back
its “favorite” icon (if
recently used) or its
confidence rate (if
recommended, or
recommended and
recently used).

2. (Optional) To narrow the search, configure the Template List panel to show
only the templates related to the document type or template code of the current
document. Other templates will be hidden. To set this filter, click the settings list
and select Filter templates by current document type or Filter templates by
current template code (whichever is available). If the parent document is not
assigned a document type or a template code yet, the Template List panel
displays all templates.

Note: This filter can be activated in the application settings, in which case
you will see this option selected automatically.

3. (Optional) To filter on a template name or code, perform one of the following:

• To filter on text anywhere in a template name or code, type the text in the
Start typing to filter field.

• To filter on text with which the template name or code must start, select

template list settings  > Search items that begin with entered text and
then type the text in the Start typing to filter field. Your administrator might
have already set this option.

Notes

• If the Template Name column exists, then it is filtered; otherwise, the
Code column is filtered.
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• Filtering is case-insensitive.

• Wildcards are not supported.

4. (Optional) To sort the templates alphabetically in an ascending or descending
order, click the arrow icon in any column header. Scroll the list to find the
template, or move the focus to this template using the UP and DOWN arrow
keys.

5. To assign the selected template to a page, double-click it or press ENTER. The
assigned template gets “checked” in the Template List panel. The filter box
displays the template name or code. The template name appears on the page
node in the Documents panel.

Note: If the document is not yet assigned a document type or template
code, assigning the first template to any page of the document
automatically assigns the document type or template code. The document
type or code appears on the document node in the Documents panel.

6. You could also click the Assign Last Template button in the Template toolbar
above the displayed page:

Or, select Template > Assign Last Template from the menu, or use the
command shortcut key.

The last manually selected template will be assigned to all selected pages,
irrespective of their classification status. The data in the index fields will be
extracted automatically.

The last used template is saved within a task and can be automatically assigned
to any page or multiple pages selected in the Documents panel. You can select
multiple pages in a document or in the task and assign the last used template to
all of them with a single command.

Note: If you apply the Assign Last Template command to a document or
a higher-level node selected in the Documents panel, the last used
template is assigned to the first page under the selected node.

Assigning the last used template is not available if the Template List panel
includes template codes only, that is, if the Template Name column is
hidden and only the Code column is displayed.

7. You could also click the Assign Template to Rest button in the Template
toolbar above the displayed page:
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Or, select Template > Assign Template to Rest from the menu, or use the
command shortcut key.

The selected template will be assigned to the selected page and all remaining
pages within one document, irrespective of the page status. The index fields
specific for each page are extracted automatically.

8. (Optional) The Template List panel can optionally include templates with the
“separator” marker for classifying pages with separator barcodes. A separator
barcode on a page indicates the beginning of a new document. In a general case,
a task comes to you for processing with all separator barcodes recognized,
separator templates applied, and all documents split accordingly.

If you find a page with a separator barcode not on the first position in the
document, you can assign it a separator template manually. Once done, the
document is split automatically in the Documents panel. The page classified as
a separator starts a new document.

Note: Splitting a document with a separator template does not require
permission for manual splitting and merging in the Documents panel.

9. (Optional) If the assigned template defines any index values, they appear in the
Index Fields panel populated with extracted values. If the values are extracted
with an acceptable confidence rate and do not require confirmation, the page is
classified and its status changes to DONE (green shading).

If the page is still IN ERROR (yellow shading), verify the page values in the
Index Fields panel. The focus is automatically set to each field that requires
attention.

10. (Optional) If you see the dark corner and the question mark on a classified page
in the Documents panel (tree view mode), make sure the assigned template
belongs to the document type or template code currently assigned to the parent
document. This requirement is not strict and the task can be finished with a
classification conflict. Reassign the template if necessary.

Note: To avoid classification conflicts, consider adjusting the Template
List panel to filter templates by document type or template code.

Related Topics:

“Resolving Classification Conflicts (Identification Only)” on page 86

“Validating Fields in Identification” on page 88
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3.5.2 Assigning Templates Automatically
When classifying pages in a multi-page task, you have an option to automatically
assign a sequence of templates to all pages in a document. The Auto-assign a
sequence of templates option serves to speed up the classification of a document
whose pages are known in their number and content. A loan application may serve
as an example of such documents.

When the Auto-assign a sequence of templates option is enabled, you only need to
assign a document type or a template code (whichever is configured as a classifier)
to the document in the Documents panel. The templates associated with the
document type or code will be assigned to all document pages automatically in a
sequence – the first template is assigned to the first page, the second template is
assigned to the second page, and so on. If the number of pages in a document
exceeds the number of templates associated with the document type or code, the last
used template is assigned to the rest of the document pages automatically.

Your application can be configured to run with the Auto-assign a sequence of
templates option enabled by default. Besides, you can enable and disable this option
for particular documents and tasks when necessary. To enable template assignment
in a sequence, expand the list of settings in the Template List panel and check the
Auto-assign a sequence of templates option. If you uncheck this option, the
application works as described in “Assigning a Template to a Page” on page 79.

To classify a document with templates in a sequence:

1. Select the document in the Documents panel.

2. Verify the order of pages and their correct orientation.

3. Click the link in the document bar to expand the list of document types or
template codes (whichever is configured). The list is configured to show up to
five most recently used items on top and all other items ordered alphabetically.

4. Select the required document type or template code from the list:

1. To filter the list dynamically, start typing the name of the document type or
template code in the filter box. The filter is case insensitive.

2. Use the arrow keys to move up and down the list. Press ENTER to choose
the selected item.

3. (Optional) Confirm your choice in a prompt dialog box. If the prompt dialog
box is suppressed in the application configuration, this step is skipped.

The selected document type or template code appears in the document bar. All
pages in the document are assigned automatically, including pages that were
classified before. In the Documents panel, each assigned page displays the
template name. If the assigned templates define index fields, data is extracted
from the page images automatically.

5. To complete the classification, verify the data fields for each page of the
document. The focus will be set on each extracted field in the document
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automatically. In each focused field, press ENTER to confirm the populated
value, or enter the correct value and confirm.

After a document has been classified automatically, you can make any necessary
corrections and adjustments manually. In particular, you can assign the last
manually selected template to a group of selected pages or to the rest of the
document.

Related Topics:

“Assigning a Template to a Page” on page 79

“Assigning Templates Automatically” on page 85

3.6 Resolving Classification Conflicts (Identification
Only)

Note: Templates are not available for information extraction projects.

After a page has been assigned a template or moved to a different position in the
Documents panel, you may see that page marked with a dark corner with a question
mark. This icon indicates that the classified page conflicts with other classified pages
in a document.

Figure 3-1: Identification classification conflict

Classification conflicts do not block the task from being finished. The dark corners
are intended to help you notice a possible classification mistake and resolve it.
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Case 1: A page must be assigned a template belonging to the
document type or template code of the document

When you classify a page with a template that belongs to a document type or
template code other than assigned to the parent document, this event causes the
classification conflict and the classified page is marked with the dark corner.
The same conflict occurs when you copy or move a classified page to a document
whose document type or template code does not indicate the page template.
To resolve the conflict, reclassify the page with the template compliant with the
document type or template code of the document. Consider enabling the Filter
templates by current document type or Filter templates by current template code
option (whichever is available in the Template List settings) to avoid classification
conflicts in the future.

Case 2: A page classified as a separator must be on the first
position in the document

When a separator template is applied to a page located not in the first position in the
document, this assignment splits the document into two.
However, when moved from the first position to a different position in any
document, a page classified with a separator template does not split that document.
Instead, this event causes the classification conflict and the separator page is marked
with the dark corner:

Figure 3-2: Page classified as separator
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To resolve the conflict, either split the document manually by the separator page, or
reassign the separator template to the page.

3.7 Validating Fields in Identification

Note: Indexing is not available for information extraction projects.

If a page has been assigned a template but still has yellow shading and displays the
“attention” icon (status: IN ERROR) in the Documents panel, then manual index
field validation is a required step. Once the page has been assigned a template, the
focus is automatically set to the first field in the Index Fields panel that requires
attention.

When you move the focus to a field, a small image snippet appears near the field,
helping you to validate the extracted value against the image data. Image snippets
are optional. If they are enabled, you can switch them on and off by selecting the
View > Image Snippets menu option.

To validate fields on the page:

1. Depending on the content that you view in the focused field, do the following:

Table 3-4: 

Field content Cause Action

The value in the field looks
correct

The field requires manual
confirmation.

Press ENTER to confirm
the field.

The value in the field
includes “?” marks instead
of some characters.

The field includes low-
confidence characters
denoted by “?”.

Set the focus in the field
and fix the low-confidence
characters.

The value in the field is
incorrect, or the field is
blank

The data extraction failed. Use the option that suits
best:

• Select the value in the
field and do the editing.

• Set the focus on the field
and rubberband the
image value.

• If an image snippet
appears near the
selected field, type the
displayed value into the
field.

2. After all errors in the field are corrected, press ENTER to move focus to the next
field that requires attention. Pressing TAB moves focus to the next field in the
tab order, regardless of whether the field requires correction.
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When all index fields are valid, the page shading changes to green and the
“checked” icon (status: DONE) appears on the page bar or thumbnail in the
Documents panel.

3.8 Validating Data in Completion
This section describes using Completion to validate data. Identification also
provides some data validation. For more information, see “Validating Fields in
Identification” on page 88.

3.8.1 Validating Fields
During validation, you view validation errors and fix incorrect fields or characters.
When you receive work that requires character or field validation, the cursor is
placed in the first field that requires validation.

You can validate fields in any preferred order, navigate between them manually,
and quickly find any field with a particular field label or data. When the cursor is in
a field, a small image snippet appears near the field, helping you to validate the
extracted value against the image data.

Note: Image snippets are optional. If they are enabled, you can switch them on
and off by selecting the View > Image Snippets menu option.

To fix problems with characters or fields:

1. Move the focus to the field that requires attention, the message bar displays an
error message or warning to indicate the issue and the required action. If the
field contains multiple problems, the first error encountered is displayed
initially.

2. Depending on the reported issue and the content in the focused field, do the
following:

Table 3-5: 

Field content Cause Action

The value in the field looks
correct.

The field requires manual
confirmation.

Press ENTER to confirm
the field.

The value in the field
includes “?” marks instead
of some characters.

The field includes low-
confidence characters
denoted by “?”.

Set the focus in the field
and fix the low-confidence
characters.
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Field content Cause Action

The value in the field
differs from the image
value, or the field is blank.

The data extraction failed. Use the option that suits
best:

• Select the value in the
field and do the editing.

• Set the focus on the field
and rubberband the
image value.

• If an image snippet
appears near the
selected field, type the
displayed value into the
field.

• If multiple fields in the
Form panel show the
same issue, consider
changing the document
type.

Depending on how your
designer has configured
fields with a drop-down
value list, you could be
provided with assistance in
the following ways:

• When you first start
typing in the field, the
drop-down list is
automatically expanded.

• As you type in a string,
the first value in the
drop-down list that
matches the string is
selected. Matching
criteria is as follows:
1. A value in the list

has a matching
string at the
beginning.

2. A value in the list
has a matching
string anywhere.

Note: Only one of
these matching
criterion could be
applied or both of
them could be
applied in the
given sequence.
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Field content Cause Action

The field has a validation
error (incorrect format,
violated business rule, or
other) or is flagged.

For the exact cause, see the
message area at the bottom
of the Page View panel.

Correct the value in the
field, or flag the field if
applicable.

3. After all errors in the field are corrected, press ENTER to move the focus to the
next field that requires attention. Pressing TAB moves the focus to the next field
in the tab order, regardless of whether the field requires correction.

When all fields are valid, the “attention” (yellow triangle) icon disappears from the
document in the Documents panel.

3.8.1.1 Fixing Low-Confidence Characters

If an index field has one or more low-confidence characters, they are denoted by the
“?” (question) mark. Moving the focus to this field activates the character repair
mode to help you repair all low-confidence characters with minimum effort.
Character repair mode works as follows:

• The first low-confidence character is selected automatically. Type the correct
character that will replace the “?” mark automatically.

Note: The question mark may be a correct character in particular fields. If
the field is configured to accept the question mark as a valid character, you
can press ENTER to confirm it.

• The focus then moves to the next low-confidence character, selecting it
automatically for rapid repair.

• After you have corrected all low-confidence characters for a field, normal mode
is activated automatically. The focus remains in the field if it still contains invalid
data. Otherwise, the focus moves automatically to the next field that requires
attention.

For example, if the field should contain the value “Insurance” but the actual text is
“In?ur?nce”, the first “?” is selected initially. After you replace that character with an
“s”, then the selection moves to the second “?” for correction.

To exit the character repair mode before correcting the low-confidence characters in
a field, do any of the following:

• Press ESC to select the entire field.

• Press the arrow keys to move the cursor to the left or right of the low-confidence
character.

• Click with the mouse to set the cursor position.

3.8. Validating Data in Completion

ECPCORE220300-CCV-EN-01 Desktop Client Guide: Identification and Completion 91



3.8.1.2 Editing Text Fields

Editing index fields includes standard cut, copy, paste, and delete actions. A subset
of editing commands is displayed on the context menu when a field is focused.

To edit the value in the field:

1. Navigate to the text field that you want to edit, then select the text. Use the
following key sequences to select text in the field:

2. Do any of the following:

• To cut text from a field, select Edit > Cut.

• To copy field text to the Clipboard, select Edit > Copy.

• To paste text from the Clipboard, select Edit > Paste. Pasting replaces any
currently selected text. If nothing is selected, the text is pasted at the location
of the cursor.

• To delete selected text in a field, select Edit > Delete, or press ` (backtick on
U.S. keyboards) to instantly clear all text in the selected field.

• To undo changes in a text field, including replacing text that has been cut,
select Edit > Undo. You can undo changes only to the last field you edited.

3. If the field requires confirmation, press ENTER to confirm the field data and
continue.

3.8.2 Table Data
The Form panel can display table data for the selected document. Depending on the
quality of the table data, you might need to edit the table, extract table data using
OCR, or both.

Standard table editing functionality lets you edit table data like any other data field –
correct values, confirm missing data, or fix broken data. You can perform these tasks
cell-by-cell as you work your way through the table. It might also be necessary to
edit the table structure by inserting missing rows, deleting unnecessary rows,
moving rows that were manually inserted in the wrong order, or merging data in a
row with that in the previous row.

Unless otherwise noted, you can perform standard table editing operations using
either grid view or record view. Grid view displays data using a standard table
layout, with columns and rows. Record view displays table data in a format that
either more closely resembles the actual image or makes it easier to enter and review
data.

If table data was not extracted correctly from a page, you can recapture the data
most efficiently using the table extraction mode. This mode lets you quickly capture
table data in a page and clean up any structural issues with the table before saving
the results to the data entry form.
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The topics included in this section describe the operations that you can perform to
correct and validate data in tables.

Note: To be able to work with table data in Completion, the Advanced
Recognition license is required.

3.8.2.1 Adjusting the Table View

Tables in the Form panel can be adjusted to display data using either of the
following views:

• Grid View: Displays data using a standard table layout, with columns and rows.
This view provides a row selection column along the left border of the table that
lets you select multiple contiguous rows for deleting or moving using standard
range selection keys (CTRL+click or SHIFT+click). Grid view is useful if, for
example, you are comparing the rows in an invoice and you want to add all the
amounts in a single column to ensure they equal the total. The tabular format of
grid view facilitates this process.

• Record view: Displays table data in a format that either more closely resembles the
actual image or makes it easier to enter and review data. In this view, controls
and fields are laid out in a format that is similar to non-table data. Record view is
useful if, for example, the table in the data entry form contains so many columns
that you would need to scroll in grid view to see the right-most columns.

Toggle between grid and record table views using the appropriate option on the
Table menu.

3.8.2.2 Editing Tables

Each time you enter data in the placeholder row, a new blank row is added to the
bottom of the table. In addition, you can insert or delete rows in a table where
necessary, move table rows to a different position, merge table rows, and clear all
data in the table.

Depending on the desired outcome, perform the required action as described in the
table to follow.

Table 3-6: Inserting and Deleting Table Rows

To Do This Perform These Steps

Insert a row in a table 1. Click inside the row above which you
want to insert a new empty row.

2. Select Table > Insert Row.

Delete one or more rows from a table 1. Click inside the row that you want to
delete. You can select multiple rows
using the row selection column.

2. Select Table > Delete Row.
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To Do This Perform These Steps

Restore the deleted rows If you delete table rows in error, you can
undo the delete action by selecting Edit >
Undo. You must select Undo immediately
after deleting the rows.

Clear a table Clearing the table deletes all table rows on all
pages, including any data. Only the blank
placeholder row remains. After you clear the
table, you can then extract the table data
again.

1. Click inside any row of the table.
2. Select Table > Delete All Rows. Only the

blank placeholder row remains.

Move table rows If a row was manually inserted in the wrong
order in a table, you can move it up or down
until it is in the correct position. You can
select multiple rows using the row selection
column.

1. Select one or more rows to move using
the row selection column.

2. Select Table > Move Row Up or Move
Row Down, as desired.
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To Do This Perform These Steps

Merge table rows Table extraction mode extracts one row for
each line of text on the image. If a logical
table row consists of multiple lines of text,
you must manually merge the rows in the
data entry form after exiting table extraction
mode.

1. Select Table > Grid View.
2. If necessary, clear incorrectly read values.
3. Click inside the row below the one with

which you want to merge.
4. Select Table > Merge with Previous

Row.

After you merge rows, the combined row
contains all of the text. The appearance of the
combined text in this row depends on how
the designer configured the data entry form.
If the field supports multiple lines of text,
then the combined text is separated by a line
break (carriage return) and the value for each
non-blank field appears on a different line in
the row. Otherwise, the values are separated
by a space.

Tip: If you are performing post-
extraction cleanup for tables and
combining logical rows is the only
correction required, it is faster to group
the rows in table extraction mode
rather than manually merging the rows
using the following steps.

3.8.3 Extracting Table Data
Table extraction is a separate mode that lets you quickly capture table data in an
image by rubberbanding (drawing the bounds of) the table and each column. You
can recapture the contents of an entire table if the data was not captured correctly
during automatic extraction. You can also extract specific columns that contain
missing or incomplete data.
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3.8.3.1 Table Extraction Mode

When you work in table extraction mode, the Form panel is replaced by a Table
Extraction panel and the image view is set to table extraction mode. In this mode,
only the Page View and Table Extraction panels are available. The Form and
Summary panels are hidden and the command bar, page navigator, and status bars
are disabled. Navigation within the Documents panel is also disabled.

Table cells are selectable to allow you to clear the cell data or draw column bounds.
However, because table extraction mode is designed to allow operators to quickly
capture table data rather than perform field validation, cell data cannot be edited in
this mode.

The first step in extracting data is to draw table and column bounds to identify the
data to be extracted. Table bounds automatically define the top and bottom of each
column; horizontal column bounds must be drawn manually.

Default table and column bounds are displayed on the image if automatic extraction
was previously performed on the table or you extracted the same table from a
previous page in the same document. Resize handles appear at the corners of the
table and the column with focus. Adjust the existing table and column bounds, as
necessary, by dragging the resize handles. Alternatively, you can redefine columns
by redrawing them using the secondary mouse button. Resizing or moving the table
automatically adjusts the top and bottom of each column bound. Resizing or moving
the column adjusts the left or right edge of the table if the selected column is the left-
or right-most column.

As you define each column in the image, focus automatically advances to the next
column in the grid. This feature lets you rapidly draw all the column bounds in
succession without having to select each column manually. If you need to move
focus back to the previous column, click SHIFT+TAB. If a column does not need to
be extracted, skip the column by pressing the TAB key.

When you extract data from a page, it is placed in a temporary table in the Table
Extraction panel. Extracted data for the current page is saved in the main data entry
form when you save and exit table extraction mode or save and move to the next
page in the document. Newly-extracted data is always inserted as new rows in the
main data entry form, above the row with focus.

After you exit table extraction mode, any validation rules defined for the document
type run against the newly extracted data. If validation errors exist, the appropriate
data-entry mode is automatically activated based on the type of field correction
required. Correct any OCR or other errors in the table cells just as you would any
other field.
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3.8.3.2 High-level Steps for Extracting Table Data

To enter the table extraction mode, click the table and select Table > Extract Table
from the menu, or open the context menu using the secondary mouse button and
select Extract Table. Perform the following high-level steps to extract table data from
a page:

1. Define the bounds of the table.

2. Define the position of each column in the table.

3. Extract the contents of the table to a temporary table.

4. If necessary, clean up the structure of the temporary table before saving the
extraction results to the data entry form.

5. Save the extraction results for the current page as new rows in the data entry
form and either move to the next page or exit table extraction mode.

When you exit table extraction mode, any validation rules defined for the document
type run against the newly-extracted data. Correct OCR and other validation errors
as you would for any other field.

3.8.3.3 Common Extraction Scenarios

The following table describes a few common scenarios that you may encounter
when extracting table data as well as the high-level steps for handling them.

Table 3-7: Steps for Handling Common Extraction Scenarios

Scenario Steps

Row text is split across pages If a logical row is split across pages, merge
the rows manually after extracting the data
on each page. Or, use table extraction mode
to capture the first page, key the missing
values from the second logical line (on the
second page), then use table extraction again
to capture the remaining rows on the second
page.

Row text spans multiple lines If the layout of the logical row spans
multiple rows in the table, combine the text
from all rows into the first (top) line of the
row by grouping related rows.

Row text overlaps multiple columns When the row text for two or more columns
overlaps on the image, the extraction process
inserts the overlapping text into each of the
columns. Clear the unwanted data for each
column using the DELETE key while in table
extraction mode. Then group related rows to
generate a single logical row from multiple
rows.
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3.8.3.4 Extracting Tables

When you extract table data from a page, the newly-extracted data is always
inserted above the row with focus. To ensure that extracted data is added in the
correct location in the temporary table, do the following:

• To replace existing row data, delete the desired rows in the data entry form. Then
place the cursor in the row above which you want to insert the newly-extracted
data before entering table extraction mode.

• To insert newly-extracted data on the first page of a document, delete all the
rows on page 1 in the data entry form. Then place the cursor in the first row on
page 2 before entering table extraction mode.

• To insert newly-extracted data on the last page of a document, place the cursor in
the placeholder row before entering table extraction mode.

To extract table data:

1. If you need to recapture data that was previously extracted, delete the existing
rows for the current page in the data entry form. Otherwise, skip to the next
step.

2. Place the cursor in the table cell or row above which you want to insert the
newly-extracted data. If you are recapturing data, click the first incorrectly-
positioned or missing cell in the table that appears in the image.

3. Enter table extraction mode by selecting Table > Extract Table. You can also
click the table using the secondary mouse button and select Extract Table from
the context menu.

If the form table has focus, then only Extract Table is enabled. The menu bar is
disabled after the operator enters the table extraction mode.

4. If table and column bounds already exist, you can adjust them by dragging the
resize handles using the primary mouse button. Alternatively, you can redefine
columns by redrawing them. Redrawing a column automatically advances to
the next column while resizing requires that you advance manually.

5. If no bounds exist, do the following:

a. Draw the boundaries of the table by dragging the secondary mouse button
to draw a rectangle around the entire table. When you release the mouse
button, table bounds with resize handles appear on the image.

b. The first column in the table is selected automatically. To skip to a different
column, click the cell in the desired column.

c. Define the horizontal boundary of the selected column by dragging the
secondary mouse button between any two points on the left and right
edges of the column. As you drag the mouse, the application displays a box
that represents the column bounds. Releasing the mouse button saves the
current bounds and moves focus to the next column automatically.
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6. Continue to adjust or draw bounds for each column that appears in the image.
To skip to the next column in the temporary table, press TAB or click the cell in
the desired column.

7. After all columns have been defined, click Extract to extract the table data from
the page. The extraction process rereads the table and places the extracted data
into the temporary table you are viewing. New rows replace any in the
temporary table.

8. If necessary, clean up the extraction results.

9. Complete the page as follows:

• If you are finished extracting table data for the current document, click Save
and Close. The application inserts the extracted rows into the data entry
form above the row with focus (the row you selected in step 2) and exits
table extraction mode. The first cell of the first newly-added row receives
focus.

• If the table is continued on the next page of the document, click Save and
Next Page. The application inserts the extracted rows into the data entry
form above the row with focus (the row you selected in step 2), clears the
temporary grid, and displays the next page. Resize the default table and
column bounds that were carried over from the previous page, if necessary,
and extract data from the new page.

3.8.3.5 Cleaning up the Extraction Results

After extraction, it might be necessary to clean up the extraction results to correct
any structural problems such as overlapping column data. This problem occurs
when the row text for two or more columns overlaps on the image. Because the
application cannot determine which values belong in which column when they
overlap, the extraction process inserts the overlapping text into each of the columns.
Clear the unwanted data for each column before exiting table extraction mode.

For example, if the text in the Part Number and Description columns overlap,
remove descriptions from the Part Number column and part numbers from the
Description column. After clearing the unwanted data, you can combine the rows in
each column to generate a single logical row from multiple rows.

Note: Column corrections can only be made to rows that were extracted for the
current page using table extraction mode. Any other operations, such as
merging individual rows or rows that span two pages, require that you first
exit table extraction mode.

To clean up the extraction results:

1. In table extraction mode, select a rectangular region of table cells in the
temporary table.

2. Clear the unwanted data in the selected cells using the DELETE key.
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3. Repeat steps 1-2 until all unwanted text is removed.

4. Group related rows.

Grouping Related Rows
Table extraction mode extracts one row for each line of text on the image. If the row
text spans multiple lines on the page, the table in the data entry form includes one
row for each of the lines. Although you could merge individual sets of rows, it is
more efficient to group all the related rows in the table at once. Grouping related
rows merges the text from all related rows into a single row for the group. Text is
always merged into the first (top) line of the row, which is considered the primary
row in a multi-line table row.

Note: If you want to merge related row text into a row other than the first row,
exit extraction mode and merge the rows manually after optionally cleaning up
the extraction results.

To group related rows in table extraction mode, you must choose a column as the
model for grouping the rows. Any column in which the row values occupy a single
line can be used. For example, in the table below, you could choose any column
other than Item because only the text in the Item column spans multiple lines. Each
time table extraction mode encounters a row with a value in the selected column, it
creates a new row. When it encounters an empty cell in the selected column, it
merges that row with the previous row.

For example, assume you selected the Order column as your grouping column in the
following table. Only the first and fourth rows would be retained as primary rows
because the Order column contains values in these rows (3 and 1, respectively). All
other rows would be merged with the previous primary row and the rows in which
Order was empty would be removed from the table.

Table 3-8: Before Grouping Table Rows

Order Shipped B.O. Item Price Total

3 3 0 0001121560 50.70/EA 152.10

   CHT403–0428   

   BUSHING
ADAPTER

  

1 1 0 0001114795 570.22/EA 570.22

   CHC403–
1140

  

   VOLTAGE
DETECTOR /
69KV

  

After grouping related rows based on the Order column, the resulting table would
look like this if the field supports multiple lines of text:
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Table 3-9: After Grouping Table Rows

Order Shipped B.O. Item Price Total

3 3 0 0001121560
CHT403-0428
BUSHING
ADAPTER

50.70/EA 152.10

1 1 0 0001114795
CHC403-114
VOLTAGE
DETECTOR /
69KV

570.22/EA 570.22

If the table includes multi-line rows above all the primary rows, they are combined
with the first primary row in the table.

To group rows:

1. In table extraction mode, click the Group Rows By button.

2. On the Grouping column popup window, choose the column on which you
want to group rows. The window lists each column in the grid that contains
data after extraction.

Tip: Select any column in which the value is the first line of text in the
logical row and does not span more than one line.

3.8.4 Changing the Document Type
A document type determines the set of document fields that appear in the Form
panel when validating a document of this type. Typically, when you receive a task,
all documents in the Documents panel display the name of the document type. If the
document type is not identified, the document bar shows the Choose type button. If
you click the name of the document type or on this button, the pick list of document
types appears, allowing you to quickly change the document type for the given
document.

Note: To be able to change the document type, you must be granted
permission. If the Document menu displays the Choose Type menu command,
you have this permission granted.

If the fields displayed in the Form panel for a given document do not match the
fields displays on the document pages (images), the document type is detected
incorrectly. Select a different document type from the list and apply it to the
document.

To change a document type:

1. In the Documents panel, select the document that requires a different document
type.

3.8. Validating Data in Completion

ECPCORE220300-CCV-EN-01 Desktop Client Guide: Identification and Completion 101



2. Select Document > Choose Type or click the link in the selected document bar.

The pick list of document types appears. The list is filtered to show up to five
recently used items on top and all other items ordered alphabetically. The
currently selected document type is selected.

3. Select the required document type from the list:

• To filter the list dynamically, start typing the name of the document type in
the filter box. The filter is case insensitive.

• Use the arrow keys to move up and down the list. Press ENTER to select the
item.

4. Click OK.

5. (Optional) Confirm your choice in a prompt dialog box. If the prompt dialog
box is suppressed in the application configuration, this step is skipped.

The name of the selected document type appears in the document bar. Changing a
document type discards existing index data. The fields in the Form panel are cleared
and cannot be populated with new data automatically. After you change the
document type, either key data from the image manually or finish the task so that
the document can be routed to classification/extraction, depending on your business
process.

3.9 Directly populating fields with data from the
image

Note: For Identification, indexing is not available for information extraction
projects.

You can use the Click to Extract feature or basic rubberbanding to directly populate
fields with data from the image. In comparison to basic rubberbanding, Click to
Extract provides additional functionality. For example, using Click to Extract, you
can automatically populate the current field with a single click of a word; in
addition, the name of the current field and other useful information is displayed
when the pointer is positioned over a word. However, Click to Extract requires the
person in your organization who created the CaptureFlow to enable it, whereas
basic rubberbanding is available by default.
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3.9.1 Click to Extract
To populate fields with data (such as amounts, dates, and entire words as well as
individual characters) directly from the image, place the cursor in a field and then
perform any of the following actions:

• Click the data.

• Drag over the data.

• To multiselect or clear entire words, perform one of the following actions:

– SHIFT+click each word.

– SHIFT+drag over the words.

• To select or clear individual characters, use one of the following:

– CTRL+click each character.

– CTRL+drag over the characters.

If the value is valid for the field, then the focus is automatically moved to the next
field that requires attention.

Tip: To pan the image, drag a blank area of the image.

Notes

• Make sure that Page > Click to Extract is enabled.

• The person in your organization who created the CaptureFlow must have
enabled Click to Extract.

• The Click to Extract feature is available for information extraction projects.

• When you position the pointer over the data on the image, a tooltip
(including the field name, data to be copied, and validation error (if
applicable) is displayed.

3.9.2 Basic Rubberbanding
Basic rubberbanding allows you to draw a zone around the image value with a
mouse, after which this value immediately appears in the index field. If you use a
zoomed image area in the Page View panel, you can rubberband values from that
area as well.

To enter data using rubberbanding:

1. Set the focus on the field in which you want to enter the extracted data.

2. In the Page View panel, keep the secondary mouse button pressed and draw a
rectangle around the value in the image. When you release the mouse button,
the text extracted from the image is inserted into the field with focus, replacing
any text already in the field.

3.9. Directly populating fields with data from the image

ECPCORE220300-CCV-EN-01 Desktop Client Guide: Identification and Completion 103



Note: Rubberbanding requires a particular OCR engine to be installed on
your machine. If rubberbanding does not work in your application,
contact your administrator.

Related Topics:

“Zooming into the Image Area” on page 77

3.10 Flagging Documents, Pages, or Fields With
Reasons
Flags represent an additional type of status for documents, pages, and fields. For
example, a flag set on a document could indicate that the document must be rejected
or forwarded to a specialist for reprocessing.

Your administrator must have enabled flagging and defined a collection of
document, page, and field flags that are particular to the business needs of your
organization. In addition, your administrator could have specified that flagged
pages, documents, or both do not need to be classified to complete the task. If
flagging is set up, then the Flag buttons in the Documents panel and in the Page
View panel are displayed; for example, as shown in the following Identification
window:

Figure 3-3: Identification flag button

Notes

• Field flags are available in Completion only.

• For Identification:

– If your application is configured for work in Do not classify flagged pages
on page 114 mode, flagging a page is necessary when you have difficulties
classifying it. This scenario allows you to finish a task in which all pages
are either classified or flagged. If you flag a page, the flagged icon appears
on it in the Documents panel but the page status remains the same as
before flagging.

– If the Do not classify flagged pages on page 114 option is enabled,
flagging a document excludes all of its pages from classification. When
you finish the task, flagged documents are not verified.
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3.10.1 Applying and Removing Flags

3.10. Flagging Documents, Pages, or Fields With Reasons
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Icon/tooltip/keyboard shortcut Action and tips

CTRL+G

Page > Flag

Document > Flag

Displays the Reason for Flagging dialog box
where you apply and remove the
appropriate flags for the selected field, pages,
or a document.

The flagged page or document is marked

with a flag icon in the Documents panel.

If a flag’s checkbox is filled with a black

square , then that flag exists on only a
subset of the selected pages. To remove the
flag from that subset of pages, click the
checkbox; you could then reapply the flag to
all of the selected pages by selecting the flag
again.

Tips
• Keyboard shortcuts are displayed

next to the flagging reasons.
• Positioning the pointer over the flag

icon displays the flagging reasons
that have been applied.

• Flagging reasons are displayed in
page view for the displayed page
and to its parent document and the
field with the focus.

Notes
• If a page flag is applied to a

document, then the selected page in
that document is flagged instead.

• If a document flag is applied to a
page, then the parent document is
flagged instead.

• If only one flag is available, then
applying the flag results in the
following:

– In Completion, the Reason for
Flagging dialog box is not
displayed and the flag is
automatically applied or removed;
however, in Identification, you
might still be prompted to apply
or remove the flag.

– If the flag does not exist on any of
the selected pages or exists on
only a subset of them, then the
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Icon/tooltip/keyboard shortcut Action and tips
flag is applied to the rest of the
selected pages.

– If the flag exists on all selected
pages, then the flag is removed
from all of them.

Flag messages in the page view panel Messages about flagged fields, pages, or
documents are displayed in page view. You
can perform the following actions:

• Click the flag reason link to display the
Reason for Flagging dialog box where
you select and remove the appropriate
flags for the flagged field, pages, or a
document.

• To clear all page, document, or field flags,
click the X icon for the corresponding
flagged pages, documents, or fields.

3.10.2 Applying Flags in Page Mode (Completion Only)
When Completion works in the page mode, the main window displays the Reasons
for Flagging panel with a collection of page flags. If the page is flagged, the message
area at the bottom of the Page View panel displays the list of applied flagging
reasons. The Reasons for Flagging panel displays the applied flagging reasons
checked and shows them in the selected message in the status bar at the bottom.

Table 3-10: Flagging a page in page mode

To Do This Perform These Steps

Move the focus to the Reasons for Flagging
panel

Select the panel with a mouse, or press CTRL
+G.

Check/ clear the flagging reason Do any of the following:

• Click the flagging reason with a mouse.

• Navigate through the list with the
DOWN arrow key and press SPACE on
the flagging reason.

• If the Reason for Flagging panel displays
a character near each flagging reason,
press the specified character on the
keyboard.

Clear all flagging reasons Click Clear All, or press DEL.

3.10. Flagging Documents, Pages, or Fields With Reasons
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3.11 Annotating Pages With Auxiliary Information
Pages in a task can be annotated with graphical and/or textual information.
Annotations are not part of the image. They are laid over the image to add some
auxiliary information, mark image areas, and hide sensitive information on the
image. When you annotate a page, the annotations are sent to the server
immediately.

Depending on the permissions granted, you can:

• View existing annotations only

• Add new annotations; view, edit, and delete the existing annotations

Viewing annotations does not require special permissions. If a page has annotations
applied, they are displayed on the image in the Page View panel and on the page
thumbnail in the Documents panel.

If you need to add and edit annotations, you must be granted permission to work in
the annotation mode. If you have this permission, you can view the Annotate button
in the Page View panel. Clicking this button loads the Annotations panel and
allows you to annotate pages in the task and edit the existing annotations.

3.11.1 Types of Annotations
The Annotations panel provides a collection of annotation types with default
properties. The following types of annotations can be viewed and applied on the
image:

Table 3-11: Annotations Palette: Annotation Types

Annotation Type Description

Redact A rectangular area on the image. Is generally
used to hide sensitive information.

Highlight A rectangular area on the image. Is generally
used to highlight and attract visual focus to a
specific area.

Arrow A line on the image. The line style can be
configured, including the line cap (endpoint),
color, and thickness.
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Annotation Type Description

Stamp A selected image (a stamp) placed on the
page. The stamp file can be picked from the
list of recently selected images, or you can
browse for an image file.

Note: A stamp image must be opaque
and can have any format, compression,
and color depth. Transparent stamps
are not supported and, if applied,
appear in the image viewer as black
opaque rectangular stamps.

Text The specified text overlaid on the image.

Comment The specified text added on the image as a
popup comment. Comment annotations
display when you position your pointer over
the annotation.

An icon displays on the image to identify the
location of the popup comment. The
comment icon is for visual purposes only
and is not saved with the image.

3.11.2 Adding Annotations
To be able to annotate images in the Page View panel, click the Annotate button or
select Page > Annotate from the menu bar. This command enables the annotation
mode and docks the Annotations panel in the main window. This panel has the
palette from which you can select the annotation type, and a property sheet where
you can configure the properties of the added annotation.

To add an annotation:

1. Select the page in the Documents panel and display it in the Page View panel.
Or, work with the displayed page.

2. Select the annotation icon from the palette.

3. (Optional) Adjust the annotation properties in the property sheet. The set of
available properties varies depending on the annotation type.

Table 3-12: Annotation Types: Available Properties

Property Descript
ion

Annotation Types

Redact Highligh
t

Arrow Stamp Text Comme
nt

Line or
Border
Color

Color
used for
lines and
borders

 X X  X  

3.11. Annotating Pages With Auxiliary Information
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Property Descript
ion

Annotation Types

Redact Highligh
t

Arrow Stamp Text Comme
nt

Line
Styles
and
Endpoint
Styles

Line
styles
such as
solid or
dotted;
endpoint
styles
such as
plain or
arrows

 X X  X  

Line
Thicknes
s

Line
weight

 X X  X  

Backgrou
nd Color

Backgrou
nd color
used in
the
annotatio
n

X X   X  

Backgrou
nd Image

Image
file used
as the
annotatio
n

   X   

Backgrou
nd
Opacity

Percenta
ge of
opacity
for the
backgrou
nd color
or image

 X   X  

Popup
Commen
t

Text that
displays
in a
popup
window
when
mousing
over the
image

X X    X

Overlay
Text

Text that
is
overlaid
on the
image

    X  
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Property Descript
ion

Annotation Types

Redact Highligh
t

Arrow Stamp Text Comme
nt

Text
Color

Color of
the
annotatio
n text

    X  

Font
Style and
Emphasi
s

Availabl
e font
styles
and
emphase
s,
includin
g bold,
italic,
and
underlin
e

    X  

Font Size Availabl
e font
sizes

    X  

Text
Direction

Orientati
on of the
text

    X  

4. Add the annotation to the page by dragging the secondary mouse button in the
desired location on the image.

5. Adjust the annotation size or location on the page as necessary. To resize the
annotation, select it and drag a corner. To relocate, drag the annotation with a
mouse.

The Annotations panel indicates that you are working in the annotation mode. If
you stay in this mode, all page operations remain available, except you cannot move
the image with a mouse in the Page View panel. Instead, you can use a mouse to
drag and resize annotations on the image. To return to the normal mode, close the
Annotations panel by clicking the Close (X) icon in the panel corner.

3.11. Annotating Pages With Auxiliary Information
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3.11.3 Editing Annotations
You can edit placed annotations by changing their properties, size, and location on
the image. To be able to edit annotations, enable the annotation mode by clicking the
Annotate button or select Page > Annotate from the menu bar.

To edit an annotation:

1. Select the annotation you need to edit. You can either click the annotation in the
image displayed in the Page View panel, or you can use the navigation arrows
on the Annotations palette to advance through the annotations in order.

Navigate back through annotations by repeatedly clicking the UP arrow. As you
navigate forward or backward through the annotations, the annotation with
focus is selected and centered on the Page View panel. The Annotations (#)
count in the property sheet indicates which annotation currently has focus on
the page.

2. Modify the annotation as necessary, selecting from available annotation
properties. Clicking on an available property applies the change to the selected
annotation.

3. Adjust the annotation size or location on the page as necessary. To resize the
annotation, select it and drag a corner. To move the annotation, drag it with a
mouse.

3.11.4 Copying Annotations
You can copy an existing annotation and paste it on the same or a different page.
The copy assumes the same property values as the annotation you copied. To copy
and paste annotations, enable the annotation mode by clicking the Annotate button
or selecting Page > Annotate from the menu bar.

To copy an annotation:

1. Select the annotation that you want to copy, then select Edit > Copy.

2. On the destination page, select Edit > Paste. The annotation is placed at the
center of the destination page and can be moved or modified as necessary.
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3.12 Finishing Tasks
• Completion

If the task includes no more work items that require attention, then you can
finish it.

• Identification

If the task includes no more pages that require attention, then you can finish it.

When you finish the task, the status of all pages is verified. If all conditions are
met, then the task is accepted and sent to the server. Otherwise, the task remains
in the main window and a message related to unfinished work items is
displayed.

For more information, see “Classification Mode Conditions Required for Task
Completion (Identification Only)” on page 113.

To finish the task:

1. Click .

2. If prompted, then confirm that the task has been completed as follows:

• Completion

If work is finished, then you can exit the waiting window and select more
work in the Get Work window; otherwise, the main window displays the
new task for processing.

• Identification

If the completed task is accepted, then the main window displays the new
task for processing. If the task still has unclassified pages, then an error
message indicates the work items that are remaining.

Note: If you do not want to be prompted every time you finish a task, then
uncheck View > Prompt at > End of Task.

Classification Mode Conditions Required for Task Completion
(Identification Only)

Depending on the classification mode used in your application, find the conditions
for a task to be verified in the following table. To find out which classification mode
is used, see your administrator.

3.12. Finishing Tasks
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Table 3-13: 

Classification mode Conditions for a task to be
completed

Documents panel (nodes)

Classify All Pages All pages in the task must be
classified.

All pages must be gray (“no
processing required”) or
green (“done”). No pages can
be yellow.

Do Not Classify Flagged
Pages

All pages in the task must be
either flagged or classified.

All pages must be gray (“no
processing required”), or
green (“done”), or red
(“flagged”). No pages can be
yellow.

Do Not Classify Pages in a
Flagged Document

Note: Can be enabled
with any mode.

All documents without a flag
must have their pages
processed as required by the
actual classification mode.
Pages in flagged documents
are not verified and can be in
any status.

Pages must be the color
acceptable for the actual
classification mode.

All pages in flagged
documents are ignored;
furthermore, they are flagged
with the “Document is
flagged” reason and colored
red (“skipped from
classification”).

Allow Task Finish With
Unclassified Pages

Note: Can be enabled
with any mode.

A task can be finished in any
state.

Pages can be any color.

3.13 Deferring Tasks
To postpone the current task and proceed to the next one, send the current task back
to the server. The returned task is moved to the task queue. When all preceding
tasks have left the queue, your postponed task is resent for processing to another
operator.

To re-queue a task:

1. Click .

(Identification Only) If the task has been reassembled either by deleting or
moving pages, or by template separators, or by binding fields, or if pages have
been rotated or annotated, all changes are saved on the server automatically.
The notification appears in the message box.

2. Perform one of the following actions:

• Completion
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Depending on your permission for abandoning changes, you can see one of
the following options:

– The notification appears in the message box to inform you that all task
changes will be saved on the server automatically. You have no
permission to abandon changes in the task after its tree structure has
been modified or any of its pages have been rotated or annotated. Choose
the preferred action:

○ Save changes: The task will be sent to the queue with all changes
made.

○ Cancel: Return to the current work to continue processing.

– The prompt dialog box opens to let you save or abandon changes in the
task. Choose the preferred option in the prompt dialog box:

○ Save changes: The task will be sent to the queue with all changes
made. When the next operator receives the task for processing, they
will view all changes.

○ Abandon changes: The task will be sent to the queue without applied
flags, changed document types, indexed values, and others. However,
changes that result in a modified task structure or rotated or
annotated pages are saved to the server immediately. You cannot
abandon these changes with this option. When the next operator
receives the task for processing, they will view these “immediate”
changes.

○ Cancel: Return to the current work to continue processing.

Note: If you do not see any of these options, the task is returned to the
server with all changes saved.

• Identification

(Optional) If the task was not reassembled and pages were not rotated or
annotated, you have an option to save or abandon changes. Choose the
preferred option in the prompt dialog box:

– Save changes: The task will be sent to the queue with all changes made,
such as applied templates, indexed values, and others. When the next
operator receives the task for processing, they will see all changes.

– Abandon changes: The task will be sent to the queue without changes.

– Cancel: Return to the current task and continue processing.

Note: If you still do not see the prompt dialog box, the task is re-
queued with abandoned changes by default.

3.13. Deferring Tasks
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3.14 Stopping Work
When you take a break or finish work at the end of the day, you should stop
working in the module. When you stop working, all work assigned to you (all
batches or a particular batch) is cancelled. You stop receiving tasks and are
redirected to the Get Work window. The current task is returned to the server and
redirected to a different operator.

To stop work:

1. Click .

Note: The following changes are automatically saved to the server and
cannot be reverted:

• Completion

– Rotated or annotated pages.

– Modifications to the task structure, such as the deletion or moving of
pages and the splitting, merging, cutting, or copying of nodes.

• Identification

– Rotated or annotated pages.

– Reassembly of the task such as the deletion or moving of pages
(manually or through template separators or binding fields).

2. (Optional) You are prompted to perform one of the following actions:

• Completion

– Save changes: The task is saved to the server with all changes made.
When the next operator receives the task for processing, they can see all
of these changes.

– Abandon changes: The task is saved to the server without changes.

Note: If any of the changes in step Step 1 were made, then you
cannot abandon changes.

– Cancel: Return to the current work.

• Identification

– Save changes: The task is saved to the queue with all changes made,
such as applied templates, indexed values, and others. When the next
operator receives the task for processing, they can see all of these
changes.

– Abandon changes: The task is saved to the queue without changes.
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Note: If any of the changes in step Step 1 were made, then you
cannot abandon changes.

– Cancel: Return to the current task.

3.14. Stopping Work
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Chapter 4

Reference

Unless otherwise indicated, the information in this section applies to both
Completion and Identification.

4.1 Visualizing PDF Documents
PDF pages can be displayed natively in Completion and Identification. Specifically,
the module internally rasterizes a PDF page into an image to visualize its content in
the module’s window. The resolution of the image is determined upon the following
sequence of considerations:

• If OCR data cache has been generated for the page, then the resolution value is
taken from the data.

• If a document type has been assigned, the resolution value is taken from the
corresponding Recognition project settings.

• Otherwise, the default 300 DPI resolution is applied.

Thumbnail images for PDF pages are generated by Completion and Identification
with low resolution that is 96 DPI.

IA Value Assignments
To allow visualizing PDF content in Completion or Identification, the following
IA value assignments must be valid for the module in a CaptureFlow:

• For an input page, <Completion>/<Identification>:0.Image must be set.
For example, in case when Identification receives an input image from the
Image Converter step, assign to Identification:0.Image the value
ImageConverter:0.Level0_OutputImage.

• The type of the input page proceeded to Completion or Identification is
“PDF” (or “.PDF”) in the ImageType IA value. It can either be received from a
previous step or set manually:
<Completion>/<Identification>:0.ImageType.

Limitations of PDF Visualization
When visualizing PDF content in Completion or Identification, the following
limitations apply:

• For multi-page PDFs, only the first page is displayed.

• Annotations are not supported.

• Rotation is not supported:

– in the page view mode, for a PDF page the rotation control is disabled;
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– in the tree view mode, if multiple pages are selected and the selection
includes pages of different formats, rotation will be applied to all pages
except for PDF pages.

4.2 Selection Indicators
In the Documents panel, the color and shading of a node and its frame indicate its
selection state:

Note: The following figure is from Completion; Identification is similar.

Table 4-1: Task Items: Navigation Status

Status Indication Description

Selected Light blue shading or frame This status indicates a page
or a group of pages, or a
node above the page level for
which you can expand the
context menu and apply any
allowed menu command.

The selected pages appear in
a light blue frame (Figure 2:
Page 1) and a selected node
above the page level has light
blue color shading (Figure1:
Document 1).
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Status Indication Description

Active Dark blue frame This status indicates a page
currently displayed in Page
View panel (Figure 1, 2: Page
1) and the parent document
of this page (Figure 1, 2:
Document 1). If you collapse
the parent document, the
frame indicates an active
document, that is, a
document whose page is
being displayed.

The Page or Document menu
commands can be applied to
an active page or document,
respectively.

Focused Black dotted frame This status indicates the
focused node (Figure 1:
Document 1; figure 2: Page
1). The frame appears when
you click the node or
navigate through the task
using shortcut keys.

Pointed Light gray frame Appears when you position
your pointer over the item. A
document or a higher-level
item displays a tooltip.

You can select nodes with a mouse or using shortcut keys. When you select a single
page or document in any of these ways, it becomes selected and active. If you select a
node above the document level, it just becomes selected. Nodes above the document
level never appear in the active state. Notice the following:

• A page in the active state is displayed in the Page View panel. Its parent
document becomes active.

• When you select a document or a higher-level node, the first page under this
selected node becomes active, and its parent document becomes active.

• When multiple pages are selected, the last page in the selection becomes active
(displayed), and its parent document becomes active.

4.2. Selection Indicators
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4.3 Changing the Main Window Layout
You can adjust the view and behavior of the main window as described in the
following table.

Note: Some of the View menu options can be unavailable if the respective
capability is not enabled in the application configuration settings. For more
information, contact your administrator.

Table 4-2: Changing the Main Window Layout

To Do This Perform These Steps Visual Effect and Notes

Resize a panel Move the cursor to the panel
edge and drag it to the
desired width or height,
keeping the primary mouse
button pressed. Release the
mouse button.

The panel is enlarged or
reduced. The neighbor panel
is reduced or enlarged,
accordingly.

Display/hide the Documents
panel

Click the “arrow” icon
located on the right panel
edge.

The Documents panel is
displayed or collapsed.

Display the Page View panel
in a different window

Select the View > Float Page
View menu option.
Alternatively, click the Pop
out button in the Page View
toolbar.

The Page View panel
appears in a separate
window. The Page View
window displays the panel
toolbar and works exactly as
the Page View panel. The
Page View window can be
used in a different monitor.

Dock the Page View window
back to the main window

Select the View > Dock Page
View menu option.
Alternatively, click the Pop
out button in the Page View
toolbar.

The Page View panel
appears in the main window.

(Identification only) Make
the Template Image panel
floating

Select the View > Float
Template Preview menu
option.

The Template Image panel
becomes hidden and appears
when you move the mouse
cursor over it.

(Identification only) Dock the
Template Image panel

Select the View > Dock
Template Preview menu
option.

The Template Image panel is
displayed in the main
window.
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To Do This Perform These Steps Visual Effect and Notes

Show/hide image snippets Select the View > Show
Image Snippets menu
option.

The image snippets that
appear near the validation
fields in the Form panel
(Completion) or Index Fields
panel (Identification) are
allowed or suppressed.

Note: This menu
option can be grayed
out, indicating that you
have no permission to
change the default
configuration.

Show/hide the Documents
panel toolbar

Select/remove selection from
the View > Toolbar for
Documents menu option.

The buttons above the
Documents panel appears or
disappear.

Show/hide the Page View
panel toolbar

Select/remove selection from
the View > Toolbar for Page
View menu option.

The buttons above the Page
View panel appears or
disappear.

Show/hide shortcuts on the
panel toolbars

Select/remove selection from
the View > Show Toolbar
Shortcuts menu option.

The shortcuts under the
buttons in the Documents
panel and Page View panel
appear or disappear.

Show or suppress the prompt
dialog when proceeding to
the next document

Select or clear View > Prompt
at >End of Document.

Note: This menu
option can be grayed
out, indicating that you
have no permission to
change the default
configuration.

Show or suppress the prompt
dialog when finishing the
task and proceeding to the
next one

Select or clear View > Prompt
at> End of Task.

Note: This menu
option can be grayed
out, indicating that you
have no permission to
change the default
configuration.

Show or suppress the prompt
dialog when deleting a page

Select or clear View > Prompt
at > Delete Page.

Note: Selecting Don’t
show again in the
delete confirmation
dialog box also clears
the menu item.

Show or suppress the prompt
dialog when deleting a
document

Select or clear View > Prompt
at > Delete Document.

Note: Selecting Don’t
show again in the
delete confirmation
dialog box also clears
the menu item.
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To Do This Perform These Steps Visual Effect and Notes

Show or suppress the prompt
dialog when deleting a folder

Select or clear View > Prompt
at > Delete Folder.

Note: Selecting Don’t
show again in the
delete confirmation
dialog box also clears
the menu item.

(Completion only) Display
the Form panel at the right
side of the Page View panel

Select the View > Form on
Right menu option.

The layout of the main
window is changed to
display the Form panel, the
message bar, and the
Summary panel docked to
the right edge of the window.

Note: This menu
option can be grayed
out, indicating that you
have no permission to
change the default
configuration.

(Completion only) Display
the Form panel at the bottom
of the Page View panel

Select the View > Form on
Bottom menu option.

The layout of the main
window is changed to
display the Form panel
docked to the bottom edge of
the window.

Note: This menu
option can be grayed
out, indicating that you
have no permission to
change the default
configuration.

(Completion only) Display/
hide the Summary panel

Select the View > Summary
menu option.

The Summary panel appears
or disappears, respectively.

(Completion only) Enable/
disable resizing the message
bar height

Select the View > Resizable
Message Bar menu option.

Enables or disables the ability
to resize the height of the
message bar. If resizing is
disabled, then message bar
height is automatically
adjusted to fit the content. If
resizing is enabled, then the
user could manually adjust
the message bar height. If
only some of the content can
be displayed, then a scroll
bar is displayed. Also, the
height is saved and restored
for the user’s next session.
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4.4 Changing the Documents Panel Layout
When processing a task, you can view its hierarchical structure in the Documents
panel.

In Identification, you can switch between the following display modes to perform
different operations:

• Tree View: Displays the task as a multilevel structure in which pages constitute
the lowest level, followed by documents and higher levels (if available). Pages
are displayed as thumbnails. The tree view displays all task levels.

• Page List: Displays the task as a list of documents, each including the list of
pages. Levels above documents (if any) are hidden. In this mode, you can view
values of the binding field.

Note: Page List View is not available for information extraction projects.

You can adjust the view of the task in the Documents panel as described in the
following table.

Table 4-3: Adjusting the Documents Panel

To Do This Perform These Steps

Expand or collapse all nodes above the page
level

Do any of the following:

• Double-click any document in the
Documents panel.

• Select View > Collapse All Documents or
View > Expand All Documents from the
menu.

• Press F9.

When expanded, the Documents panel
displays all pages. When collapsed, the page
level is hidden.

Expand or collapse a particular node above
the page level

Click the “arrow” icon on the node to expand
or collapse it. When expanded, the node
displays all child nodes on all levels,
including pages.

(Identification Only) Switch between the
display modes

Click the respective icon in the Documents
panel header:
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To Do This Perform These Steps

Increase or decrease the thumbnail size This operation is available in the tree view
mode only.

1. Click the “settings” icon on the
Documents panel header.

2. Adjust the thumbnail size to the required
values.

The updated thumbnail size is
remembered in the user preferences and
applies to all next tasks, including in the
next work sessions.

Hide levels above the selected one This operation is available in the tree view
mode only.

1. Click the “settings” icon on the
Documents panel header.

2. Expand the Show levels up to list and
choose the highest level to be displayed
in the tree view.

The levels above will be hidden.

4.4.1 Tree View Mode (Identification Only)
In the tree view mode, the task is displayed as a tree structure where pages are
shown as thumbnails and the higher-level nodes are shown as horizontal tabs.
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Table 4-4: 

Tree View Mode Description

Every page shows its ordinal number in the
document. If you replace the page, its ordinal
number will be recalculated.

Nodes above the page level display:

• “Arrow” icon that indicates the expanded
node (“down” ) or collapsed node
(“right” ). Click the “arrow” icon to
expand or collapse the node. When
expanded, the node displays all child
nodes on all levels, including pages.

• A self-descriptive label (for example,
Document, Folder, and so on) and the
ordinal number of the node within the
parent node (for example, Document1,
Folder2).

Note: You can see different node
labels defined by your
administrator.

• The number of included child nodes in
braces. For example, Document1 (7)
means that the first document in the
given folder (or in the task with no folder
level) includes seven pages.

The classification status of pages and higher-
level nodes is indicated by icons and color
shading. Besides:

• Each classified page shows the name of
the assigned template, for example,
DOCX_LD_OCR.

• Each classified document shows the name
of the assigned document type or
template code is displayed near the
“down” icon. The “down” icon on each
document expands the list of document
types or template codes (whichever is
configured).
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4.4.2 Page List Mode (Identification Only)
In the page list mode, the task is displayed as a list that can include document nodes
and page nodes only. Nodes above the document level are hidden. To view all
nodes, you can switch to the tree view mode.
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Table 4-5: 

List Mode Description

Each page node displays the following data:

• The ordinal number of the page in the
document. If you replace or move the
page, its ordinal number will be
recalculated.

• Template name: Classified pages show
the name of the assigned template, for
example, DOCX_LD_OCR. Pages that
are not classified show empty space. If
template names are not displayed
(hidden), page classification can be done
by template codes only.

• Code: Classified pages show the code of
the assigned template, for example,
DOCX. Pages that are not classified show
empty space.

• Binding Field: Classified pages show the
value of the binding field if the assigned
template has this field. If the binding field
is not displayed (hidden), the automatic
page binding is disabled.

• “Backside” icon: Optional. If visible,
shows the “backside” icon for page
backside pages and nothing for front-side
pages.

• Page statuses displayed as icons.

Each document node displays the following
data:

• “Arrow” icon that indicates the expanded
(“down”) or collapsed (“right”)
document. Click the “arrow” icon to
expand or collapse the document. When
expanded, the document displays the
included pages.

• The self-descriptive label (for example,
Document) and the ordinal number of
the document within the parent node.

Note: You can see a different label
defined by your administrator.

• If the document is classified, the name of
the assigned document type or template
code appears near the “down” icon. The
“down” icon on each document expands
the list of document types or template
codes (whichever is configured).
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List Mode Description
• If the document is flagged, its status is

indicated by the “flag” icon.

4.5 Printing
Note: If you do not see the Print menu commands, then you do not have
permissions to print.

To Print Perform These Steps

All pages in a task Select Document > Print and then select All
in Page Range.

All pages in a document or node Select a document or node in the Documents
panel and then select Document > Print.

Note: The Selection option is selected;
however, the Selection option does not
determine the pages that are to be
printed. The pages to be printed are
the ones that are selected in the
Documents panel as follows:

• All pages in the selected document
or node, or

• The pages that are selected.

Selected pages Select pages in the Documents panel (CTRL
+click, SHIFT+click) and then select
Document > Print.

Note: The Selection option is selected;
however, the Selection option does not
determine the pages that are to be
printed. The pages to be printed are
the ones that are selected in the
Documents panel as follows:

• All pages in the selected document
or node, or

• The pages that are selected.
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To Print Perform These Steps

The current page Select a page in the Documents panel and
then select Document > Print.

Notes
• The Current Page option, which

means that the current page is to be
printed, is selected.

• Selecting Page > Print chooses the
print dialog box options that match
the selections in the Documents
panel; that is, it does not
automatically select the current page
for printing.

Pages by a range of page numbers In the Print dialog box, specify the range of
pages in Page Range. Pages are numbered in
the sequence as displayed in the Documents
pane, beginning with the top left page;
document and node breaks do not restart
page numbering.

Note: (Completion Only) If a
document has a page filter, then only
the pages shown in the Documents
panel can be printed.

4.6 Keyboard Shortcuts
This section describes the supported keyboard shortcuts.

4.6.1 Default Keyboard Shortcuts
The following keyboard shortcut defaults are provided to make processing tasks
more efficient. These shortcuts primarily use CTRL and FUNCTION keys and can
be used from anywhere in the application interface and are not limited to the active
window or panel.

The default shortcuts can be customized and stored on the server as global options.
For more information, see OpenText Intelligent Capture - Designer Guide (ECPCORE-
CPD).

The following table describes the default shortcuts assigned to each operation.
Shortcuts for commands on secondary windows are not included in the list.

Table 4-6: Default Keyboard Shortcuts

Operation Key Description

Finish (icon) F10  
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Operation Key Description

Continue Later (icon) F11  

Stop Working (icon) F12  

Help (icon) F1  

Navigate to Previous ( ):

Back CTRL+BACKSPACE Sets the focus on the closest
previous page that requires
classification or field
validation. The focus is set
either on the template list
selection or on the first field
that requires validation. Is
disabled if there is no such
page.

Note: This is a
standard keyboard
shortcut that is
common for many
Intelligent Capture
applications and
cannot be customized.

Previous Document CTRL+U Sets the first page of the
previous document as
current. If the page needs
classification or field
validation, the focus is set
accordingly. Otherwise the
focus is set on the page view.
Is disabled if there is no
previous document.

Previous Page CTRL+SHIFT+J Sets the previous page as
current. If the page needs
classification or field
validation, the focus is set
accordingly. Otherwise the
focus is set on the page view.
Is disabled if there is no
previous page.

Previous Segment CTRL+J The focus moves to the first
field in the previous segment.

Navigate to Next ( ):

Chapter 4   Reference

132 OpenText™ Intelligent Capture ECPCORE220300-CCV-EN-01



Operation Key Description

Next Work RETURN Sets the focus on the closest
next page that requires either
classification or field
validation. The focus is set
either on the template list
selection or on the first field
that requires validation. Is
disabled if there is no such
page.

Note: This is a
standard keyboard
shortcut that is
common for many
Intelligent Capture
applications and
cannot be customized.

Set Focus to Form F7 Sets the focus to the next
form field that requires
validation.

Next Document CTRL+M Sets the first page of the next
document as current. If the
page needs classification or
validation, the focus is set
accordingly. Otherwise the
focus is on the page view. Is
disabled if there is no next
document.

Next Page CTRL+SHIFT+K Sets the next page as current.
If the page needs
classification or field
validation, the focus is set
accordingly. Otherwise the
focus is set on the page view.
Is disabled if there is no next
page.

Next Segment CTRL+K The focus moves to the first
field in the next segment.

Document menu:

Flag CTRL+G  

New Empty Documents No default shortcut  

New Documents CTRL+N Applies to the current
document or page only.
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Operation Key Description

Split >

Split Folder

Split Folder up to Stack

Split Folder up to Level4

Split Folder up to Level5

Split Folder up to Level6

F4 Applies to the current
document only.

Change doc type CTRL+D Applies to the current
document only.

Merge>

Merge Folder

Merge Stack

Merge Level4

Merge Level5

Merge Level6

F3 Applies to the current
document or page only.

Page menu:

Zoom In CTRL+PLUS

CTRL+mouse wheel up

Applies to the current page
only.

Zoom Out CTRL+MINUS

CTRL+mouse wheel down

Applies to the current page
only.

Actual Size CTRL+* Applies to the current page
only.

Fit to Window No default shortcut Applies to the current page
only.

Fit to Width No default shortcut  

Fit to Height No default shortcut  

Default Zoom No default shortcut  

Set Default Zoom to No default shortcut  

Auto Pan CTRL+5 Toggles automatic panning
on/off.

Pan Up CTRL+8 Applies to the current page
only.

Pan Down CTRL+2 Applies to the current page
only.
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Operation Key Description

Pan Left CTRL+4 Applies to the current page
only.

Pan Right CTRL+6  

Rotate Left CTRL+1  

Rotate Right CTRL+3  

Rotate 180 CTRL+0  

Annotate CTRL+T Applies to the current page
only.

Click to Extract CTRL+E Toggles populating index
fields with data (such as
amounts, dates, and entire
words as well as individual
characters) directly from the
image by clicking on the data
or drawing a selection
rectangle around the data.

Table menu: (Completion only)

Insert Row CTRL+INSERT  

Delete Row CTRL+DELETE  

Delete All Rows CTRL+SHIFT+DELETE  

Move Row Up No default shortcut  

Move Row Down No default shortcut  

Merge with Previous Row No default shortcut  

Extract Table No default shortcut  

Grid View / Record View No default shortcut  

Template menu: (Identification only)

Assign Last Template CTRL+SHIFT+Z  

Assign Template to Rest CTRL+SHIFT+X  

Edit menu: all operations use standard Windows shortcuts
.

Undo CTRL+Z Reverts the change.

Cut CTRL+X Applies only to the selected
text in the field.

Copy CTRL+C Applies only to the selected
text in the field.

Paste CTRL+V Applies only to the selected
text in the field.

View menu:
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Operation Key Description

Collapse All Documents

Expand All Documents

F9  

Dock Page Preview No default shortcut  

Float Page Preview No default shortcut  

Dock Template Preview No default shortcut  

Float Template Preview No default shortcut  

Show Image Snippets No default shortcut  

Toolbar for Documents No default shortcut  

Toolbar for Page View No default shortcut  

Show Toolbar Shortcuts No default shortcut  

Prompt at > End of
Document

No default shortcut  

Prompt at> End of Task No default shortcut  

Prompt at> Delete Page No default shortcut  

Prompt at> Delete
Document

No default shortcut  

Prompt at> Delete Folder No default shortcut  

Other operations:

Find CTRL+F Sets the focus on the found
field.

Note: This is a
standard keyboard
shortcut that is
common for many
Intelligent Capture
applications and
cannot be customized.

Print CTRL+P Launches the Print dialog for
the current document.

Note: This is a
standard keyboard
shortcut that is
common for many
Intelligent Capture
applications and
cannot be customized.

Clear the text in the selected
field

` ( tilde)  
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4.6.2 Shortcut for Switching Between Panels
To quickly switch between panels in the main window, you can use the following
shortcut keys:

Table 4-7: 

Target Shortcut Key Comment

Switch to the next or
previous panel in the main
window

CTRL+TAB (next)

CTRL+SHIFT+TAB
(previous)

 

Switch to the next or
previous control inside the
active panel

TAB (next)

SHIFT+TAB (previous)

 

Switch to the Documents
panel

Press ALT, 1. The focus is set to the page
currently selected in the Page
View panel.

Switch to the Page View
panel

Press ALT, 2.  

Switch to the Template panel Press ALT, 3. Identification only

Switch to the Index Fields
panel

Press ALT, 4, or F7 (can be
customized)

The focus is set to the first
field in the Index Fields
panel that requires attention.

Switch to the Summary panel Press ALT, 6. Completion only

Switch to the Annotations
panel

Press ALT, 5.  

Switch to the Reasons for
Flagging panel (page mode)

Press ALT, 7. Completion only

4.6.3 Shortcuts for Editing Text in Fields
To quickly edit text in fields, you can use the following shortcut keys:

Table 4-8: Editing Text in Index Fields: Keyboard Shortcuts

Key Description Example

LEFT Move the cursor to the
previous character. This
character gets selected.

 

RIGHT Move the cursor to the next
character. This character gets
selected.
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Key Description Example

HOME Move the cursor to the
beginning of the field. The
first character gets selected.

 

END Move the cursor to the end of
the field. The last character
gets selected.

 

SHIFT+HOME Move the cursor to the
beginning of the field,
selecting the text from the
current position of the cursor
to the beginning. The first
character is included in the
selection; the currently
selected character is not
included.

In the masked field
“(123)45_-____”, move the
cursor to “5” (selected) and
press SHIFT + HOME.
“(123)4” is selected.

SHIFT+END Move the cursor to the end of
the field, selecting the text
from the current position of
the cursor up to the end. The
current and the last
characters are included in the
selection.

 

DEL Delete the character next to
the current position of the
cursor. The deleted character
is dropped rather than
replaced by a space. The
character next to the deleted
one becomes selected.

In the masked field
“(123)45_-____”, move the
cursor to “3” (selected) and
press DEL . “4” is deleted,
the field includes “(124)5_-
___” (“4” is selected).

BACKSPACE Delete the character prior to
the current position of the
cursor. The deleted character
is dropped rather than
replaced by a space. The
character next to the deleted
one becomes selected.

In the masked field
“(123)456-____”, move the
cursor to “4” (selected) and
press BACKSPACE. “3” is
deleted, the field shows
“(124)56_-____”, the cursor is
set to “4” (selected).
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4.6.4 Shortcuts for Navigating and Selecting Items in the
Documents pane
To quickly navigate to and select items in the Documents panel, you can use the
following shortcut keys:

Table 4-9: Navigating and Selecting Items in the Documents panel

To Do This Perform These Steps Comments

Navigate to a node in the
Documents panel

Use the following shortcuts:

• CTRL+HOME/END:
Move the focus to the top/
bottom tree node
displayed in the
Documents panel.

• HOME/END: Move the
focus to the first/last node
inside the parent node.

• UP/DOWN: Move the
focus vertically to the
upper/lower node
through all currently
expanded nodes.

• LEFT/RIGHT: Move the
focus to the left/right page
in the document.

The focus moves between the
displayed nodes. The focused
node gets selected. If a node is
collapsed, its child nodes are
bypassed. Expand the node
to set the focus on its child
node.

Expand or collapse a
particular node

(view or hide its child nodes)

Double-click the node, or
click the “arrow” icon on the
node bar.

Alternatively:

1. Set the focus to the
required document or a
higher-level node.

2. Press LEFT to collapse
the node and RIGHT to
expand it (view all child
nodes).

 

Expand or collapse all nodes

(view or hide all pages in the
task)

Press F9.  
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To Do This Perform These Steps Comments

Select a single node Click the node.

Alternatively:

1. Navigate to the node
using shortcuts.

2. When the node is
focused, press SPACE.

A page or a document
becomes selected and active. A
node above document level
becomes selected.

Select multiple adjacent
pages in one document

Keep the SHIFT key pressed
and click the first and the last
page in the range.

Alternatively:

1. Set the focus to the first
required page.

2. Keeping the SHIFT key
pressed, move the focus
to the last page in the
selection.

All pages become selected.
The last page in the selection
becomes active.

Select multiple non-adjacent
pages (including from
different documents)

Keep CTRL pressed and click
the required pages.

Alternatively:

1. Set the focus to the first
required page and press
SPACE to select it.

2. Keeping CTRL pressed,
move the focus to the
next page and press
SPACE to select it.

All pages become selected.
The last page in the selection
becomes active.

Expand the context menu for
the selected node(s)

Click in the Documents
panel with the secondary
mouse button.

Alternatively, press SHIFT
+F10.
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4.6.5 Shortcuts for Moving in the Form Panel (Completion
Only)
You can easily move around within a data entry form during validation. When you
receive work, the first field requiring attention takes focus. Navigate between the
fields as described in the following table.

Table 4-10: Moving between Fields

To Do This Perform These Steps

Move the focus to the next field in the tab
order (regardless of whether the field
requires correction)

Press TAB.

Navigate to the next work item
Press ENTER or click  > Next Work. If
the field requires confirmation, pressing
ENTER confirms the field data.

Notes
• If the field requires confirmation,

pressing ENTER confirms the field
data.

• If the current field has a validation
rule failure, this option cycles
navigation through all the
dependent fields once before
proceeding to the next work item.

Navigate backwards through fields
Click  > Back. The path leads backward
through each field that was previously
visited.
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To Do This Perform These Steps

Find a field You can find a field in the Form panel by
entering the field's label or the content in the
field finder:

1. Type the text to search for in the field
finder text box, which appears on the
command bar. The field finder is not case
sensitive.

2. Press ENTER to find the first match. The
finder identifies a match if either the field
label or the field text contains the search
term. The first match becomes the
selected field.

3. Press ENTER again to find the next
match. Cycle forward through all
matches by pressing ENTER repeatedly.
Press SHIFT+ENTER to search
backwards through the document.

4. Press ESC to clear the search text and exit
the field finder. The last matching field
you viewed becomes the selected field.

The data entry form can optionally define segments (logical sections), which makes
it easier for you to navigate through the long form. Related fields and tables are
grouped together in screens that you can page through more quickly than scrolling
through a single long form. Move between segments in a form as follows:

•
To move to the next segment, click  Next Segment.

•
To move to the previous segment, click  > Previous Segment.

The focus moves to the first field in the new segment.

4.6.6 Shortcuts and Arrow Keys for Moving Around the Page
You can use arrow keys and shortcut keys to move around the image quickly. You
can use these shortcuts irrespective of the Auto Pan mode status (on/off). When the
image is scaled to fit into the Page View panel, the shortcuts and arrow keys take no
effect.
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Menu command Shortcut key Arrow keys

Page > Pan Up CTRL+8

Page > Pan Down CTRL+2

Page > Pan Left CTRL+4

Page > Pan Right CTRL+6

For precise panning, click and hold the mouse button down on the image, then drag
and release. For high-speed panning, use the shortcut keys. This method keeps the
focus on the field. The shortcut keys pan at a preset distance per key.

Related Topics:

“Automatic Panning” on page 78

4.6.7 Windows Shortcuts
The following common Windows shortcuts execute the following operations:

Table 4-11: Standard Windows Shortcuts

Operation Shortcut Key Description

Apply ENTER Activates the component, or
the component element that
has the focus.

For example, in Identification
assigns the template
currently selected in the
Template list. Or, activates a
common “commit” button.
For example, activates the
Apply button in the Reason
for Flagging dialog.

Escape / Revert ESC Exit from the current mode
(closing a dialog or exiting
from edit mode) and revert
any changes (if any made). In
dialogs, this key is equivalent
to clicking the Cancel button.
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Operation Shortcut Key Description

Delete DEL Deletes the selected item. If
applied is an editable field,
deletes the character to the
right of the cursor.

Activate SPACE Activates the component or
the component element that
has the focus. If the current
control is a button, this key
clicks the button. If the
current control is a checkbox,
this key toggles the checkbox.
If the current control is an
option, this key selects the
option. Otherwise, works as
the space key.

Next Control TAB Moves the focus to next
control defined in the tab
order. At end of the panel,
returns the focus to the top.

Previous Control SHIFT+TAB Moves the focus to the
previous control defined in
the tab order. At the
beginning of the panel,
returns the focus to the
bottom.

Next Panel CTRL+TAB

F6

Sets the focus to the next
panel

Previous Panel CTRL+SHIFT+TAB

SHIFT+F6

Sets the focus to the previous
panel

Home HOME If an editable field is selected,
sets the cursor at the
beginning of the field.

End END If an editable field is selected,
sets the cursor at the end of
the field.

Top CTRL+HOME Sets the focus to the top item.

Bottom CTRL+END Sets the focus to the bottom
item.

Up UP Moves the focus and
selection up by one line (if
applicable, set focus to the
first item of the line).
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Operation Shortcut Key Description

Down DOWN Moves the focus and
selection down by one line (if
applicable, set focus to the
first item of the line).

Expand / Right RIGHT In the tree view, expands the
current selected node if not
expanded; otherwise, goes to
the first child node.

Collapse / Left LEFT In the tree view, collapses the
current selected node if
expanded; otherwise, goes to
the parent node.

Context menu SHIFT+F10 Calls the context menu for
the focused element

Help F1 Calls the help topic
associated with the focused
control . If not available, then
calls general help.

Rename F2 Selects the text in the edit
box.

Refresh F5 If there is a refreshable list or
items on the currently
focused panel, they are
refreshed.

Copy CTRL+C Applies only to the selected
text in the field.

Cut CTRL+X Applies only to the selected
text in the field.

Paste CTRL+V Applies only to the selected
text in the field.

Undo CTRL+Z Reverts the change.

Redo CTRL+Y Redoes the change.

Exit ALT+F4 Exits the application. Before
exit, changes are checked and
the current task is stopped.

Close CTRL+F4 Closes the current active
document. Before closure,
changes are checked and the
current task is stopped.

Select All CTRL+A Selects all items in the tree
view on the Document level
(level 1). Does not work
above this level.
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ECPCORE220300-CCV-EN-01 Desktop Client Guide: Identification and Completion 145



4.7 Identification
Note: Menu items, toolbar buttons, panels, and other information related to
templates and indexing are not available for information extraction projects.

4.7.1 Main Window
Table 4-12: 

Panel Description

Header bar Displays the application name, the batch
name, buttons for task management, and the
name of the logged in operator.

Menu bar Displays the following menu sections:

• Previous and Next: Includes the menu
commands for navigating to the
previous/next item in the focused panel,
or to the previous/next document in the
task.

• Document: Includes the menu commands
that can be applied to an active
document, such as splitting, merging,
adding a new document, flagging, and
printing.

Optional. Is hidden when a task has only
one page and no other levels above it.

• Page: Includes the menu commands for
adjusting the image in the Page View
panel as well as for flagging, annotating,
and printing the active page.

• Edit: Includes the menu commands for
editing the task, such as cut, paste, copy,
delete, and undo.

• Template: Includes the menu commands
for assigning templates.

• View: Includes the menu commands for
adjusting the main window.
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Panel Description

Documents panel Displays the current task as a multilevel
assembly with pages on the lowest level.
Allows for selecting pages and higher-level
nodes, modifying the task assembly
(including the Clipboard commands and
dragging), and applying operations on the
selection.

• The toolbar displays buttons for
processing pages and higher-level nodes
and modifying the task assembly. The
toolbar can be hidden.

• The context menu opened for the
selection includes all allowed operations.

The view of the panel can be adjusted as
described in “Changing the Documents
Panel Layout” on page 125. You can hide and
expand the panel.

Page View panel Displays the page currently selected and
active (marked with a dark blue rim) in the
Documents panel. Allows for classifying,
flagging, annotating, and printing the
displayed page. The displayed image can be
zoomed, panned, and rotated.

• The panel header indicates the location of
the displayed page in the task structure:
<Page #> (<Document #>): <assigned
template>.

• The panel toolbar displays buttons for
processing the displayed page and
adjusting its view in the panel. The
toolbar can be hidden.

• The message area at the bottom shows all
flags applied to the displayed page and to
its parent document. Clicking the page or
document flags calls the Reason for
Flagging dialog where you can set or
remove flags. Also, flags can be removed
from the page or document by clicking
the “clear all” button.

You can dock the Page View panel or make
it float. The floating panel is displayed in a
separate window.

4.7. Identification
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Panel Description

Annotations panel Appears when you enter the annotation
mode by clicking the Annotations button in
the Page View panel toolbar. The panel
allows you to draw and edit annotations on
the page as described in “Annotating Pages
With Auxiliary Information” on page 108.
The panel contains a palette of annotation
types with default properties that you can
configure for drawing repeated annotations
quickly.

Template List panel Displays templates that can be assigned to
the displayed page as described in
“Assigning a Template to a Page”
on page 79.

The list of templates can be sorted
alphabetically by any column and filtered by
several parameters.

Template Image panel Optional. Displays the sample image for the
template currently selected in the Template
List panel.

You can dock this panel or make it float. The
floating panel appears when you position
your pointer over it; otherwise, the panel is
hidden.

Index Fields panel Displays the fields that must be populated
with data from the displayed page. These
fields are specified by the template of the
displayed page. Different pages within the
same document may have a different set of
fields.

• The field that requires attention gets the
focus.

• The message area on top of the panel tells
you how the focused field must be
processed. When work is done, the
message disappears.

• The image snippet displays the image
area from which the value was extracted
into the currently focused field. The
image snippet is an optional element of
the Index Fields panel, it can be hidden.
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Panel Description

Status bar Displays the work status in the format:

• Working On: All Batches (<#>
Documents) or Working On: <batch
name> (<#> Documents)

• Work Level: <task level> | Remaining
Work Items: <#>/<#>: Indicates the task
level (batch or lower) and remaining
work items relative to all work items in
the task. The examples of work items
could be a page that requires a template
or a field to be confirmed.

The progress bar displays your progress in
the task.

4.7.2 Page Status
The Documents panel uses special icons and color shading to inform you about the
page status and about statuses of higher-level nodes.

Figure 4-1: Identification page status

OK (“No work required”, screen 1)
When using the Documents panel in the tree view mode, the page thumbnail is
decorated with the gray band that displays the page number in the document
and the assigned template. When using the Documents panel in the page list
mode, the page bar uses gray shading and displays the page number and the
assigned template.

IN ERROR (“classification needed”, screen 2)
A page in this status is not assigned a template, or any of its fields requires
validation or contains invalid data. When using the Documents panel in the tree
view mode, the page thumbnail is decorated with the yellow band with the
triangle icon. The band displays the page number in the document and the
assigned template. When using the Documents panel in the page list mode, the
page bar uses yellow shading and the triangle icon and displays the page
number and, optionally, the assigned template.

4.7. Identification
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FLAGGED (“flagged”, screen 3)
A flagged page can be in this status if the Do not classify flagged pages
application mode is enabled. When using the Documents panel in the tree view
mode, the page thumbnail is decorated with the red band with the flag icon. The
band displays the page number in the document and, optionally, the assigned
template. When using the Documents panel in the page list mode, the page bar
uses red shading and the “flag” icon and displays the page number and
optionally the assigned template.

DONE (“classified”, screen 4)
When using the Documents panel in the tree view mode, the page thumbnail is
decorated with the green band and the check icon and displays the page number
in the document and the assigned template. When using the Documents panel
in the page list mode, the page bar uses green shading and the check icon and
displays the page number and the assigned template.

Page thumbnail (screen 5)
The page thumbnail or bar can display additional icons (screen 5) that do not
indicate the page status.

• the Backside icon

• the Flag icon (if the default classification mode is used)

• the dark corner (classification conflict)

4.7.3 IA Values
Identification exposes a set of IA values that are declared in the CPIDENTF.mdf file.
These MDF values fall into two groups:

• Values common for all Intelligent Capture client modules. Each module defines
these values in its MDF file. For more information, see OpenText Intelligent Capture
- Module Reference (ECPCORE-CMD).

• Values specific for the Identification module.

Note: Although you can add custom variables to an MDF file, this file is
overwritten each time you upgrade the product. It is recommended that you
define custom values in a Capture Flow as described in OpenText Intelligent
Capture - Designer Guide (ECPCORE-CPD). Alternatively, you can create a
custom MDF file to prevent your extra variables from being overwritten. Notice
that if you modify the deployed MDF file, you are responsible to reapply your
modification after each product upgrade.

The values specific for the Identification module are described in the following table:
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Table 4-13: Identification: IA Values

IA Value Level Data Type, Specifier Description

AllowedDocFlags T String, Input If holds a non-empty
string, overrides the
Document Flagging
Reasons value in the
step setup settings.

The value is a
semicolon-delimited
list of “text/value”
pairs formatted as in
setup mode. For
example:
Research 
needed(Research)
;Pages 
missing(MissingP
ages)

AllowedDocTypes T String, Input If set to a non-empty
value, overrides the
Document Types
option (document
types displayed to
the operator in the
Choose Type list) in
the step setup
settings.

The value is a
semicolon-delimited
list of document
types that can use “*”
as a wildcard. For
example:
Tax*;Finance*

(show all document
types beginning with
“Tax” or “Finance”)
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IA Value Level Data Type, Specifier Description

AllowedPageFlags T String, Input If set to a non-empty
value, overrides the
Page Flagging
Reasons list in the
step setup settings.

The value is a
semicolon-delimited
list of “text/value”
pairs formatted as in
setup mode. For
example:
Too light
 (TooLight);Too 
dark (TooDark)

AnnotationComment 0 String, Output A string containing a
comma-delimited
concatenation of all
annotations of type
“comment” added to
a page.

Backside 0 Long, Input An indication of the
front- or backside of
the page. Values:

• 0: Front side of
the page

• 1: Backside

If not set, the page
side is considered to
be front.

CharactersInvalid 0 Long, Output The total number of
remaining
questionable
characters on the
page.

ClassificationID 0 String, Input, Output Stores the ID, which
is created and used
by information
extraction to
associate
classification data
with this image.

DispatcherProjectNameT String, Input If holds a non-empty
string, overrides the
Recognition Project
option in the step
setup settings.
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IA Value Level Data Type, Specifier Description

DocFlag 1 String, Input, Output When used as output,
a string that
represents flags
assigned to the given
document.

When used as input,
a string that specifies
new flags that are to
be merged with the
existing ones in
UimData in the given
document.

Flags are specified as
comma-separated
internal names. This
string is passed
between steps. For
example:
MissingPages,
RescanDocument

DocFlagged T Long, Output Holds “1” if the task
includes at least one
flagged document
(with a non-empty
DocFlag value); “0”
otherwise.
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IA Value Level Data Type, Specifier Description

DocStatus 1 DocumentStatus,
Output

The summary of the
field and page
statuses collected for
the document.
Includes the
following parameters
(all of type Long):

• FieldsUnconfirmed
: The number of
unconfirmed
fields.

• FieldsInvalid:
The number of
fields that failed
single-field
validation.

• FieldsFlagged:
The number of
flagged fields.

• PagesFlagged:
The number of
flagged pages.

• TotalFlagged:
The total amount
of flagged fields
and pages, plus
one if the
document is also
flagged.

• CharactersInvalid
: The total amount
of remaining low-
confidence
characters.

• RemainingWork:
The total amount
of Flagged,
FieldsUnconfirmed
,
FieldsInvalid,
CharactersInvalid
, plus the number
of fields failing
multi-field
validation rules

FieldsInvalid 0 Long, Output The number of fields
that failed validation
on the page.
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IA Value Level Data Type, Specifier Description

FieldsUnconfirmed 0 Long, Output The number of
unconfirmed fields
on the page.

Flagged 0 Boolean, Output An indicator of a
flagged page.

Image 0 File, Output, Prefetch A reference of the
image file that stores
the document page
(one side). Required.

The referenced image
is displayed to the
operator in the Page
View panel, it can be
modified during the
step execution, and
then it is output.

ImageType 0 String, Input, Output The extension of the
file referenced by the
Image value. If
empty, the default
value is TIF.

InputPageDataXml 0 String, Input XML formatted
statistics generated
by Classification and
passed to
Identification.
Includes for each
page its template ID
and data in pre-index
fields.

Level0_NeedClassificationEdit0 Boolean, Output Holds “true” if this
page needs to be
classified by
operator.

NeedClassificationEditT Boolean, Output Is “true” if at least
one image in the task
was not classified
automatically and
requires manual
classification.
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IA Value Level Data Type, Specifier Description

OcrDataCache 0 File, Input, Prefetch A reference of the file
with the full text
OCR data cache
created for the given
page. Typically, this
file is output by the
Classification,
StandardOCR steps.
Optional.

OutputPageDataXml 0 String, Output XML formatted
statistics received in
InputPageDataXml
and extended with
Identification
operator input
(template IDs and
pre-indexed data). Is
intended for the
Collector step to be
used by Production
Auto-Learning (PAL).

PageFlag 0 String, Input, Output A string with
comma-separated
internal names of the
flags applied to the
given page. This
string is passed
between steps. For
example:
TooLight,Noise,
Skewed

If empty, indicates
“success/no error”
status of the page.

PageFlagged T Long, Output Holds “1” if the task
includes at least one
flagged page (with
the Flagged value
set to “1”); “0”
otherwise.

RemainingWork 0 Long, Output The total amount of
FieldsUnconfirmed
, FieldsInvalid,
CharactersInvalid
.
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IA Value Level Data Type, Specifier Description

ReportTag1

ReportTag2

ReportTag3

T String, Input Tags for collecting
statistics, which are
used in reports.
Optional. If a given
Identification step is
set up to collect
statistics in database
tables Document 
Type, Template,
and Field, data in
these tags is exported
to each of these tables
into fields
ReportTag1,
ReportTag2, and
ReportTag3,
accordingly.

Rotation 0 Long, Input, Output The number of
clockwise rotations
by 90º applied to the
original input image.
Values:

• 0 - none

• 1 - the image was
rotated by 90º
(one click)

• 2 - the image was
rotated by 180º
(two clicks)

• 3 - the image was
rotated by 270º
(three clicks)

This value must be
explicitly reset to 0
when the step is
redone and the
Image IA value is re-
initialized.

StepCustomValue T String, Input If holds a non-empty
string, overrides the
Custom Value option
(input parameters for
document type
scripting) in the step
setup settings.

TemplateCode 0 String, Output The code of the
template assigned to
the given page.
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IA Value Level Data Type, Specifier Description

UimDataImportMode T Long, Input This value defines
how the indexing
data input will be
bound to
PageDataXml.
Values:

• 0: Do not bind
additional data to
the
PageDataXml
object

• 1: Bind input
index values to
the
PageDataXml
object

UimDocumentType 1 String, Input The name of the
document type
assigned to the given
document by the
Classification step.

UimDocumentType 0 String, Input, Output The name of the
information
extraction (IE)
profile/document
type the page is
classified as. This
value is set only
when the recognition
project uses
information
extraction.

4.8 Completion

4.8.1 Main Window
The main window appears when you have selected a batch or all batches for
processing. This section describes the main window panels.

Table 4-14: Completion: Main Window Panels

Element Description

Header bar Displays the application name, the batch
name, buttons for task management, and the
name of the logged in operator.

Chapter 4   Reference

158 OpenText™ Intelligent Capture ECPCORE220300-CCV-EN-01



Element Description

Menu bar Displays the following menu sections:

• Previous and Next: Include the menu
commands for navigating to the
previous/next item in the focused panel,
or to the previous/next document in the
task.

• Documents: Includes the menu
commands that can be applied to an
active document, such as splitting,
merging, adding a new document,
flagging, and printing. Optional, not
displayed in the page mode.

• Page: Includes the menu commands for
adjusting the image in the Page View
panel as well as for flagging, annotating,
and printing the active page.

• Table: Includes the menu commands for
editing tables in the Form panel. If the
Form panel includes no tables, all
included menu commands are grayed
out. Optional, not displayed in the page
mode.

• Edit: Includes the menu commands for
editing the task, such as cut, paste, copy,
delete, and undo.

• View: Includes the menu commands for
adjusting the main window.

Documents panel (tree view) Displays the current task as a multilevel
assembly with pages on the lowest level.
Allows for selecting pages and higher-level
nodes, modifying the task assembly
(including the Clipboard commands and
dragging), and applying operations on the
selection.

• The toolbar displays buttons for
processing pages and higher-level nodes
and modifying the task assembly. You
can configure the toolbar to be displayed
or hidden.

• The context menu opened for the selected
nodes includes all allowed operations.

The view of the panel can be adjusted as
described in “Changing the Documents
Panel Layout” on page 125. You can hide and
expand the panel.

The Documents panel is not displayed in the
page mode.
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Element Description

Page View panel Displays the page currently selected and
active (marked with a dark blue rim) in the
Documents panel. Allows for flagging,
annotating, and printing the displayed page.
The displayed image can be zoomed, panned
(except in the page mode), and rotated.

• The panel header indicates the location of
the displayed page in the task structure:
<Page #> (<Document #>). In the page
mode, the header displays CURRENT
PAGE.

• The panel toolbar displays buttons for
processing the displayed page and
adjusting its view in the panel. You can
configure this toolbar to be displayed or
hidden.

You can dock the Page View panel or make
it float. The floating panel is displayed in a
separate window.

Message bar Displays:

• All flags applied to the currently selected
field, to the displayed page, and to its
parent document (if any). Clicking any
flag calls the Reason for Flagging dialog
where you can set or remove flags. Also,
flags can be removed from the page or
document by clicking the “clear all”
button.

• Validation error messages for the
currently selected field (for example, if
manual confirmation is required or the
field contains unrecognized characters).
When a field contains multiple errors, the
message bar displays one error at a time.
After you correct each error, the next
error message displays.
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Element Description

Form panel (data entry form) Displays the data entry form where you need
to validate index fields of the document
selected in the Documents panel. The set of
fields is specific for the document type that is
shown on the document bar in the
Documents panel.

• The image snippet displays an extracted
portion of the original image near the
validation field. Snippets let you quickly
compare the original image to the
extracted value shown in the field. Image
snippets can be disabled in the
application configuration settings. If
available, you can configure image
snippets to be displayed or hidden.

The Form panel is not displayed in the page
mode.

Annotations panel Appears when you enter the annotation
mode by clicking the Annotations button in
the Page View panel toolbar. The panel
allows you to draw and edit annotations on
the page. The panel contains a palette of
annotation types with default properties that
you can configure for drawing repeated
annotations quickly.

Summary panel Shows key index fields defined for the
document. This panel is hidden in the
annotation mode.

Status bar Displays the work status in the format:

• Working On: All Batches (<#>
Documents) or Working On: <batch
name> (<#> Documents). The document
information is hidden in the page mode.

• Work Level: <task level> | Remaining
Work Items: <#>/<#>: Indicates the task
level (batch or lower) and remaining
work items relative to all work items in
the task. The example of a work item
could be a field that requires manual
confirmation. This information is hidden
in the page mode.

The progress bar displays your progress in
the task.
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4.8.2 Documents Panel
The Documents panel displays the task as a tree structure where pages are shown as
thumbnails and the higher-level nodes are shown as horizontal tabs.
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Table 4-15: 

Every page shows its ordinal number in the
document. If you move the page to a
different position, its ordinal number will be
recalculated.

Nodes above the page level display:

• “Arrow” icon that indicates the expanded
node (“down”) or collapsed node
(“right”). Click the “arrow” icon to
expand or collapse the node. When
expanded, the node displays the child
nodes.

• A self-descriptive label (for example,
Document, Folder, and so on) and the
ordinal number of the node within the
parent node (for example, Folder1,
Document2).

Note: You can see different node
labels defined by your
administrator.

• The number of included child nodes in
braces. For example, Document1 (2)
means that the first document in the
given folder (or in the task with no folder
level) includes two pages.

Document nodes display:

• The name of the document type, or the
“attention” (yellow triangle) icon and the
Choose type button if the document type
needs to be identified manually. Clicking
the document type or the Choose type
button opens the pick list of document
types for your choice.

• “Attention” (yellow triangle) icon near
the document's ordinal number that
indicates that the document has work
items to be completed.

A task can include filtered documents that
indicate their status as follows:

• The document node displays the “filter”
icon that indicates a page filter:

The document displays only pages
requiring attention; other pages are
filtered off and not available in the task.
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The number of displayed pages relative
to all document pages appears next to the
“filter” icon. For example, 1 of (4).

• Pages in a filtered document show their
ordinal numbers in the original (non-
filtered) document. The displayed page
numbers are fixed and cannot be
changed. Pages cannot be moved.

Note: When a task has at least one
filtered document, Completion enters
the page filtering mode.

4.8.3 Page Filters
A page filter indicates that a document includes only pages that require attention or
manual validation. Documents with a page filter are displayed with the filter icon as
follows:

Figure 4-2: Desktop page filter

The count of the filtered pages comparative to the total amount of pages in the
document is also displayed. Page indexes in the filtered document indicate the
actual page number in the original document.

The filtered pages are marked with the attention (yellow triangle) icon as follows:

Figure 4-3: Desktop page filter
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Pages that were filtered off are not included in the task. You cannot view these pages
nor perform any operation on them.

In the task that includes filtered pages (also known as page filtering mode), you
cannot modify (including moving and deleting pages) the task structure; however,
validation of fields from the pages that were not included in the task and page
rotation are allowed. You cannot disable page filtering mode and it remains in effect
until you finish the current task and receive the next one that does not include any
filtered documents.

4.8.4 IA Values
Integration Considerations for IA Values
Completion stores document data in a single UimData IA value that contains all
fields in the document. Modules that support UIM data (such as Identification,
Extraction, Standard Export) can read individual fields directly from this value;
however, pre-7.0 modules cannot. To export data using modules that do not support
UIM data, the document data must be written into a set of “flat” IA values with one
value per field so that each value can be separately mapped in the export module.
CaptureFlow Designer also requires one IA value per field if the document data is
used for CaptureFlow tasks, such as choosing the next step in the CaptureFlow.

If you need individual values, you must configure them using the setup settings for
IA values. During step configuration, you can choose to create values or to only
populate existing ones. You can also specify the step destination into which the
values should be written. For example, you can use custom values in CaptureFlow
Designer when creating the CaptureFlow, which are then populated by the module.
Another option is to use a separate data-only MDF that is populated by the module.

For more information on data flattening, see OpenText Intelligent Capture - Designer
Guide (ECPCORE-CPD).

IA Values
Completion exposes a set of IA values that are declared in the CPDSKTOP.mdf file.
These MDF values fall into two groups:

• Values common for all Intelligent Capture client modules. Each module defines
these values in its MDF file. For more information, see OpenText Intelligent Capture
- Module Reference (ECPCORE-CMD).

• Values specific for the Completion module.

Note: Although you can add custom variables to an MDF file, this file is
overwritten each time you upgrade the product. It is recommended that you
define custom values in a Capture Flow as described in OpenText Intelligent
Capture - Designer Guide (ECPCORE-CPD). Alternatively, you can create a
custom MDF file to prevent your extra variables from being overwritten. Notice
that if you modify the deployed MDF file, you are responsible to reapply your
modification after each product upgrade.
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IA values that are specific to Completion are described in the following table.

• The Level column identifies the level of the batch where the given IA value is
created and updated. Level <T> represents the level of the task (0 to 7).

• The Type column identifies the required data type for each IA value followed by
the specifier (input and/or output).

Table 4-16: IA Values for Completion

IA Value Level Type Description

AllowedDocFlags T String, Input If holds a non-empty
string, overrides the
Document Flagging
Reasons value in the
step setup settings.

The value is a
semicolon-delimited
list of “text/value”
pairs formatted as in
setup mode. For
example:
Research 
needed(Research)
;Pages 
missing(MissingP
ages)

AllowedDocTypes T String, Input If set to a non-empty
value, overrides the
Allowed Document
Types option in the
step setup settings.

The value is a
semicolon-delimited
list of document
types that can use “*”
as a wildcard. For
example:
Tax*;Finance*

(show all document
types beginning with
“Tax” or “Finance”)
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IA Value Level Type Description

AllowedFieldFlags T String, Input If set to a non-empty
value, overrides the
Field Flagging
Reasons list in the
step setup settings.

The value is a
semicolon-delimited
list of “text/value”
pairs formatted as in
setup mode. For
example:
Value does not 
exist in database
 (NotExist),
Value conflicts 
with other data
 (DataConflict)

AllowedPageFlags T String, Input If set to a non-empty
value, overrides the
Page Flagging
Reasons list in the
step setup settings.

The value is a
semicolon-delimited
list of “text/value”
pairs formatted as in
setup mode. For
example:
Too light
 (TooLight);Too 
dark (TooDark)

AnnotationComment 0 String, Output A string containing
the comma-delimited
concatenation of all
comment annotations
added to a page.

Image 0 File, Input, Output A reference of the
image file that stores
the document page
(one side). Required.

The referenced image
is displayed to the
operator in the Page
View panel, it can be
modified during the
step execution, and
then it is output.
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Backside 0 Long, Input An indication of the
front- or backside of
the page. Values:

• 0: Front side of
the page

• 1: Backside

If not set, the page
side is considered to
be front.

DocFlag 1 String, Input, Output When used as output,
a string that
represents flags
assigned to the given
document.

When used as input,
a string that specifies
new flags that are to
be merged with the
existing ones in
UimData in the given
document.

Flags are specified as
comma-separated
internal names. This
string is passed
between steps. For
example:
MissingPages,
RescanDocument

DocFlagged T Long, Output Is set to “1” if the task
includes a flagged
document indicated
by a non-empty
DocFlag parameter.
Is set to “0”
otherwise.
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DocStatus 1 DocumentStatus,
Output

An object that
describes the status
of the given
document. Can be
used for routing
decisions in the
CaptureFlow. This
object is created
when the task is
closed, independent
of whether it is
completed or
canceled, and is not
automatically
updated.

The document status
includes the
following properties:

• CharactersInvalid
(Long): The
number of
remaining
questionable
characters. This is
initially set during
recognition, but a
given operator
may not finish all
of them. If this
value is non-zero,
the document
contains work
that can be
corrected by a
step configured
for “character”
work level or
higher.

• FieldsInvalid
(Long): The
number of fields
that failed field-
level validation.
This number is
“0” if there are no
single-field
validation errors
in the document.
If this number is
other than “0”, it
contains work
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that can be
corrected by a
step configured
for “field” work
level or higher.

• FieldsUnconfirmed
(Long): The
number of
unconfirmed
fields.

• FieldsFlagged
(Long): The
number of flagged
fields.

• PagesFlagged
(Long): The
number of flagged
pages.

• TotalFlagged
(Long): The
number of flagged
fields and pages,
plus one if the
document is also
flagged.

• RemainingWork
(Long): The sum
of
FieldsFlagged,
FieldsUnconfirmed
,
FieldsInvalid,
CharactersInvalid
, plus the number
of fields that
failed document-
level validation.
Values:

– “0”: The
document is
complete (has
no remaining
work) and
ready for
export.

– Other than
“0”: The
document
contains work
that can be
corrected by a
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step
configured for
the
“document”
work level. It
might also
contain work
applicable to
lower work
levels; check
the other
status values
to find out.

Note: Fields
may be
counted
multiple
times if
multiple
statuses
apply. For
example, if
a field is
both in
error and
has a flag,
FieldsInvalid
is “1”,
FieldsFlagged
is “1”, and
RemainingWork
is “2”,
although
only one
field needs
work.
Routing
decisions
based on
information
in the
document
status
should take
this into
account.
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FieldFlagged T Long, Output Is set to “1” if any
document in the task
has a flagged field
indicated by a non-
zero
DocStatus.FieldsFlagged
parameter. Is set to
“0” otherwise.

ImageType 0 String, Input File extension of the
file referenced by the
Image value. If
empty, the default
value is TIF.

OcrDataCache 0 File, Input, Prefetch A reference of the file
with the full text
OCR data cache
created for the given
page. Typically, this
file is output by the
Classification,
StandardOCR steps.
Optional.

PageDataXml 0 String, Input, Output XML formatted
statistics generated
by Classification or
Identification . This
value is typically
passed to Completion
from the
OutputPageDataXml
value of the
preceding Extraction
step.

Completion updates
this XML data with
bounds used in
rubberbanding and
values keyed in by
the operator. The
updated data can be
passed to the
Collector step to be
used in Production
Auto-Learning
(PAL).
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PageFlag 0 String, Input, Output A string with
comma-separated
internal names of the
flags applied to the
given page. This
string is passed
between steps. For
example:
TooLight,Noise,
Skewed

If empty, indicates
“success/no error”
status of the page.

PageFlagged T Long, Output Is set to “1” if any
document in the task
has a flagged page
indicated by a non-
empty PageFlag
parameter. Is set to
“0” otherwise.

PagesToProcess 1 String, Input If a document has a
page filter, this value
holds a comma-
delimited string with
page numbers to be
displayed to the
operator. For
example:

• “1”: Only page 1
is displayed.

• “3–5”: Pages 3, 4,
and 5 are
displayed.

• “L2”: The last two
pages are
displayed.

• “1,3–5,L2”: The
combination of all
above ranges is
displayed.

If a document is not
filtered, this value is
empty.
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ReportTag1

ReportTag2

ReportTag3

T String, Input Tags for collecting
statistics, which are
used in reporting.
Optional. If a given
Completion step is
set up to collect
statistics in database
tables Document 
Type, Template,
and Field, data in
these tags is exported
to each of these tables
into fields
ReportTag1,
ReportTag2, and
ReportTag3,
accordingly.

Rotation 0 Long, Input, Output The number of
clockwise rotations
by 90º applied to the
original input image.
Values:

• 0 - none

• 1 - the image was
rotated by 90º
(one click)

• 2 - the image was
rotated by 180º
(two clicks)

• 3 - the image was
rotated by 270º
(three clicks)

This value must be
explicitly reset to 0
when the step is
redone and the
Image IA value is re-
initialized.

SourceNodeID 0, 1 Integer, Output If not empty, this
value indicates that
the given page or
document has been
copied from a
different node. In this
case, this value holds
the ID of the original
batch node.
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StepCustomValue T String, Input If holds a non-empty
string, overrides the
Custom Value option
(input parameters for
document type
scripting) in the step
setup settings.

Used as scripting
parameters. If set to a
non-empty value,
overrides those
values defined in the
step setup.
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UimData 1 String, Input, Output A string
representation of the
document's UIM
data. Pre-populating
UimData is not
mandatory, and this
structure must not
necessarily include
extracted fields or
rubberbanded zones.

If UimData is set for
the task, it can
contain:

• An empty string
(no data). In this
case:

– If
UimDocumentType
is blank: Users
with the
Document
Types
permission can
choose the
document type
in Completion,
which will
define the
UimData
contents (with
any newly-
indexed
values) that
are written
back to the IA
value when
the task is
committed.

– If
UimDocumentType
is non-blank;
Completion
creates
UimData for
the document
type with all
values empty
and writes it
(with any
newly-indexed
values) back to
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the IA value
when the task
is committed.

• Extracted
document fields.

• Values from the
Extraction step
and from the
preceding
Completion
step(s) where
UimData.
Document.
FieldData.
IsValueUpdate
d indicates values
changed by script.
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UimDataImportMode 1 Long, Input, Output The mode that
defines or disallows
additional data
import to UimData.
Input data is bound
to the step regardless
its index level.
Allowed values are:

• “0”: Do not bind
additional data to
UimData.

• “1”: One-timely
bind dynamic
field data input to
UimData.

The data should
be in values
InUimData_<fi
eld> or
InUimData_<fi
eld>__<Index>.
After the
InUimData field
has been copied
into the UimData
object,
UimDataImportMode
is reset to “0”.

• “2”: Always bind
index values
higher than the
task level from
the flattened
output IA values
back to UimData.

The data should
be in values
named exactly as
their target fields:
<field>. When
the field is an
array (table
column), all array
items are
expected,
separated with a
new line.
Additionally, the
“per row” array
values are
supported:
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<field>_<row>.
In case IA values
contain both “per
array” and “per
row” flattened
data, the last one
takes precedence.

• “3”: The
combination of
modes “1” (“one-
timely bind”) and
“2” (“always
bind”). After a
value has been
copied into the
UimData object,
UimDataImportMode
is reset to “2”. In
case of conflict
between prefixed
“one-time” and
undecorated
“always” values,
the last one takes
preference.

To learn more about
data flattening and
passing data between
IA values and UIM
data, see OpenText
Intelligent Capture -
Designer Guide
(ECPCORE-CPD) .

UimDocumentType 1 String, Input The name of the
document type
assigned to the
document. Is used
only if the document-
level UimData is not
set.
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Glossary
dpi

Dots Per Inch

OCR
Optical Character Recognition

PAL
Production Auto-Learning

PDF
Portable Document Format

TIF
Tagged Image File file extension

UNC
Universal Naming Convention

XML
Extensible Markup Language

ECPCORE220300-CCV-EN-01 Desktop Client Guide: Identification and Completion 181




	OpenText™ Intelligent Capture
	Table of Contents
	Chapter 1   Introduction
	1.1. Concepts
	1.2. Identification
	1.2.1. Operator Procedure

	1.3. Completion

	Chapter 2   Setting Up the Modules
	2.1. Setup Options for All Modules
	2.2. Configuring direct population of fields with data from the image (Identification and Completion)
	2.3. Setting Up Identification
	2.3.1. Configuring Operator View and Workflow for Efficiency
	2.3.2. Enabling the Operator to Perform Certain Tasks
	2.3.3. Configuring Template Assignment
	2.3.4. Defining the Available Flagging Reasons
	2.3.5. Options for IA Values, Collecting Statistics, and Scripting
	2.3.6. Collecting Statistics

	2.4. Setting Up Completion
	2.4.1. Configuring Operator View and Workflow for Efficiency
	2.4.1.1. Setting the Work Level
	2.4.1.2. Example: Setting View and Navigation for Particular Use Cases

	2.4.2. Enabling the Operator to Perform Certain Operations
	2.4.3. Defining the Available Flagging Reasons
	2.4.4. Options for IA Values, Abandoning Changes, Collecting Statistics, and Scripting
	2.4.5. Collecting Document Type Statistics
	2.4.5.1. Where Data is Stored
	2.4.5.2. How Data is Captured



	Chapter 3   Tasks
	3.1. High-Level Procedures
	3.1.1. Identification
	3.1.2. Completion

	3.2. Getting Batches
	3.3. Reorganizing Folders, Documents, and Pages
	3.3.1. Folders and Higher-Level Nodes
	3.3.2. Documents
	3.3.2.1. Assembling Documents Automatically (Identification Only)

	3.3.3. Pages

	3.4. Changing the Page View
	3.4.1. Zooming and Rotating Pages
	3.4.2. Zooming into the Image Area
	3.4.3. Automatic Panning

	3.5. Assigning Templates (Identification Only)
	3.5.1. Assigning a Template to a Page
	3.5.2. Assigning Templates Automatically

	3.6. Resolving Classification Conflicts (Identification Only)
	3.7. Validating Fields in Identification
	3.8. Validating Data in Completion
	3.8.1. Validating Fields
	3.8.1.1. Fixing Low-Confidence Characters
	3.8.1.2. Editing Text Fields

	3.8.2. Table Data
	3.8.2.1. Adjusting the Table View
	3.8.2.2. Editing Tables

	3.8.3. Extracting Table Data
	3.8.3.1. Table Extraction Mode
	3.8.3.2. High-level Steps for Extracting Table Data
	3.8.3.3. Common Extraction Scenarios
	3.8.3.4. Extracting Tables
	3.8.3.5. Cleaning up the Extraction Results

	3.8.4. Changing the Document Type

	3.9. Directly populating fields with data from the image
	3.9.1. Click to Extract
	3.9.2. Basic Rubberbanding

	3.10. Flagging Documents, Pages, or Fields With Reasons
	3.10.1. Applying and Removing Flags
	3.10.2. Applying Flags in Page Mode (Completion Only)

	3.11. Annotating Pages With Auxiliary Information
	3.11.1. Types of Annotations
	3.11.2. Adding Annotations
	3.11.3. Editing Annotations
	3.11.4. Copying Annotations

	3.12. Finishing Tasks
	3.13. Deferring Tasks
	3.14. Stopping Work

	Chapter 4   Reference
	4.1. Visualizing PDF Documents
	4.2. Selection Indicators
	4.3. Changing the Main Window Layout
	4.4. Changing the Documents Panel Layout
	4.4.1. Tree View Mode (Identification Only)
	4.4.2. Page List Mode (Identification Only)

	4.5. Printing
	4.6. Keyboard Shortcuts
	4.6.1. Default Keyboard Shortcuts
	4.6.2. Shortcut for Switching Between Panels
	4.6.3. Shortcuts for Editing Text in Fields
	4.6.4. Shortcuts for Navigating and Selecting Items in the Documents pane
	4.6.5. Shortcuts for Moving in the Form Panel (Completion Only)
	4.6.6. Shortcuts and Arrow Keys for Moving Around the Page
	4.6.7. Windows Shortcuts

	4.7. Identification
	4.7.1. Main Window
	4.7.2. Page Status
	4.7.3. IA Values

	4.8. Completion
	4.8.1. Main Window
	4.8.2. Documents Panel
	4.8.3. Page Filters
	4.8.4. IA Values


	Glossary

